Уязвимость BDU:2015-02612

Дата: 01.01.2015. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2015-02612.

Наименование уязвимости: Уязвимость программной библиотеки для анализа XML-документов Libxml2, связанная с выходом операции за допустимые границы буфера данных, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость программной библиотеки для анализа XML-документов Libxml2 связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Debian GNU/Linux до 4 | Операционная система ООО «РусБИТех-Астра» Astra Linux 2.12 «Орел» | Прикладное ПО информационных систем libxml2 до 2.6.32 включительно |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux до 4 | Astra Linux 212 «Орел» |
Дата выявления: 11.08.2009.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Низкий уровень опасности (базовая оценка CVSS 3.0 составляет 3,7)

Возможные меры по устранению:
Проблема может быть решена обновлением операционной системы до следующих версий пакетов в зависимости от архитектуры:
Debian GNU/Linux 4:
ppc:
libxml1 — 1.8.17-14+etch1
libxml-dev — 1.8.17-14+etch1
i686:
libxml1 — 1.8.17-14+etch1
libxml-dev — 1.8.17-14+etch1
arm:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1
s390x:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1
x86-64:
libxml1 — 1.8.17-14+etch1
libxml-dev — 1.8.17-14+etch1
alpha:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1
ia64:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1
mips:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1
mipsel:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1
hppa:
libxml-dev — 1.8.17-14+etch1
libxml1 — 1.8.17-14+etch1

Для Libxml2:
Обновление программного обеспечения до 2.6.32 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета libxml2) до 2.6.32 или более поздней версии
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2009-2414. CVE-2009-2416. DSA-1861. ID:1400821.

Тип ошибки CWE: CWE-119
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://www.debian.org/security/dsa-1861/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2416
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2414

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *