Уязвимость BDU:2015-02651

Дата: 01.01.2015. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2015-02651.

Наименование уязвимости: Уязвимости операционной системы Debian GNU/Linux, позволяющие удаленному злоумышленнику нарушить конфиденциальность, целостность и доступность защищаемой информации.

Описание уязвимости: Множественные уязвимости пакета gda2-odbc операционной системы Debian GNU/Linux, эксплуатация которых может привести к нарушению конфиденциальности, целостности и доступности защищаемой информации. Эксплуатация уязвимостей может быть осуществлена удаленно
Уязвимое ПО: Операционная система Debian GNU/Linux до 3.1 |

Наименование ОС и тип аппаратной платформы:

CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)

Возможные меры по устранению:
Проблема может быть решена обновлением операционной системы до следующих версий пакетов в зависимости от архитектуры:
Debian GNU/Linux 3.1:
ppc:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
s390x:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
m68k:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
i686:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
arm:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
sparc:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
x86-64:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
alpha:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
ia64:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
mips:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
noarch:
libgda2-doc — 1.2.1-2sarge1
mipsel:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
hppa:
gda2-freetds — 1.2.1-2sarge1
gda2-mysql — 1.2.1-2sarge1
gda2-odbc — 1.2.1-2sarge1
gda2-postgres — 1.2.1-2sarge1
gda2-sqlite — 1.2.1-2sarge1
libgda2-3 — 1.2.1-2sarge1
libgda2-3-dbg — 1.2.1-2sarge1
libgda2-common — 1.2.1-2sarge1
libgda2-dev — 1.2.1-2sarge1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2005-2958. DSA-871. ID:1400867.

Тип ошибки CWE:
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://www.debian.org/security/dsa-871/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2958

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *