Уязвимость BDU:2019-00927

Дата: 28.09.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-00927.

Наименование уязвимости: Уязвимость функции _warc_read библиотеки libarchive, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции _warc_read (archive_read_support_format_warc.c) библиотеки libarchive связана с ошибками проверки ввода данных приводящими к DOS — квази-бесконечному выполнению и использованию диска из небольшого файла. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Fedora Project Fedora 28 | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система ООО «РусБИТех-Астра» Astra Linux 1.6 «Смоленск» | Прикладное ПО информационных систем libarchive от 3.2.0 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Fedora Project Fedora 29 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Операционная система Fedora Project Fedora 30 | Операционная система ООО «РусБИТех-Астра» Astra Linux 8.1 «Ленинград» |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Fedora 28 | Ubuntu 1810 | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Fedora 29 | OpenSUSE Leap 150 | Fedora 30 | Astra Linux 81 «Ленинград» |
Дата выявления: 28.09.2018.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для libarchive:

Обновление программного обеспечения до 3.3.3-2 или более поздней версии



Для Debian:

Обновление программного обеспечения (пакета libarchive) до 3.1.2-11+deb8u6 или более поздней версии

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2019-04/msg00055.html

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/CBOCC2M6YGPZA6US43YK4INPSJZZHRTG/
https://lists.fedoraproject.org/archives/list/[email protected]/message/W645KCLWFDBDGFJHG57WOVXGE62QSIJI/
https://lists.fedoraproject.org/archives/list/[email protected]/message/ZVXA7PHINVT6DFF6PRLTDTVTXKDLVHNF/

Для Ubuntu:
https://usn.ubuntu.com/3859-1/.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-1000880.
Прочая информация:
Тип ошибки CWE: CWE-20
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2018-1000880

https://security-tracker.debian.org/tracker/CVE-2018-1000880
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://lists.opensuse.org/opensuse-security-announce/2019-04/msg00055.html
https://lists.fedoraproject.org/archives/list/[email protected]/message/CBOCC2M6YGPZA6US43YK4INPSJZZHRTG/
https://lists.fedoraproject.org/archives/list/[email protected]/message/W645KCLWFDBDGFJHG57WOVXGE62QSIJI/
https://lists.fedoraproject.org/archives/list/[email protected]/message/ZVXA7PHINVT6DFF6PRLTDTVTXKDLVHNF/
https://usn.ubuntu.com/3859-1/
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *