Уязвимость BDU:2019-02097

Дата: 18.04.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-02097.

Наименование уязвимости: Уязвимость функции extract_status_code системы балансировки сетевого трафика Keepalived, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции extract_status_code (lib/html.c) системы балансировки сетевого трафика keepalived связана с переполнением буфера в динамической памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 19.04 | ПО сетевого программно-аппаратного средства Keepalived до 1.23 | Операционная система Debian GNU/Linux 10.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux 8.1 «Ленинград» |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS | Ubuntu 1804 LTS | Ubuntu 1810 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1904 | Debian GNU/Linux 100 | Astra Linux 81 «Ленинград» |
Дата выявления: 18.04.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Keepalived:
Обновление программного обеспечения до 1:2.0.19-2.1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета keepalived) до 1:2.0.10-1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета keepalived) до 1:2.0.10-1 или более поздней версии

Для Ubuntu:
https://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-19115.html?_ga=2.85180762.214113060.1559032785-1618695258.1547637860
.
Статус уязвимости: Потенциальная уязвимость
Наличие эксплойта: Данные уточняются
Информация об устранении: Информация об устранении отсутствует
Идентификаторы других систем описаний уязвимости: CVE-2018-19115.
Прочая информация:
Тип ошибки CWE: CWE-122
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-19115.html?_ga=2.85180762.214113060.1559032785-1618695258.1547637860
https://security-tracker.debian.org/tracker/CVE-2018-19115
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *