Уязвимость BDU:2019-02447

Дата: 08.04.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-02447.

Наименование уязвимости: Уязвимость функции g_markup_parse_context_parse библиотеки Glib, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции g_markup_parse_context_parse (gmarkup.c, метод utf8_str()) библиотеки Glib связана с чтением за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система ООО «РусБИТех-Астра» Astra Linux 1.5 «Смоленск» | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система ООО «РусБИТех-Астра» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Прикладное ПО информационных систем The GNOME Project Glib 2.56.1 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Операционная система Debian GNU/Linux 10.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux 8.1 «Ленинград» |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Astra Linux 15 «Смоленск» | Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM | Red Hat Enterprise Linux 8 | OpenSUSE Leap 150 | Debian GNU/Linux 100 | Astra Linux 81 «Ленинград» |
Дата выявления: 08.04.2018.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для glib2.0:
Обновление программного обеспечения до 2.42.1-1+deb8u3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета glib2.0) до 2.42.1-1+deb8u3 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета glib2.0) до 2.42.1-1+deb8u3 или более поздней версии

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2018-16429

Для Ubuntu:
https://usn.ubuntu.com/3767-1/
https://usn.ubuntu.com/3767-2/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-16429.
Прочая информация:
Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://access.redhat.com/security/cve/CVE-2018-16429
https://usn.ubuntu.com/3767-1/
https://usn.ubuntu.com/3767-2/
https://nvd.nist.gov/vuln/detail/CVE-2018-16429
https://security-tracker.debian.org/tracker/CVE-2018-16429
https://gitlab.gnome.org/GNOME/glib/issues/1361
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *