Уязвимость BDU:2019-04037

Дата: 04.07.2017. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-04037.

Наименование уязвимости: Уязвимость функции parse8BIM (coders/meta.c) кроссплатформенной библиотеки для работы с графикой GraphicsMagick, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции parse8BIM (coders/meta.c) кроссплатформенной библиотеки для работы с графикой GraphicsMagick связана с переполнением буфера в динамической памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Novell Inc. openSUSE 13.2 | Операционная система Novell Inc. OpenSUSE Leap 42.1 | Операционная система ООО «РусБИТех-Астра» Astra Linux 1.6 «Смоленск» | Прикладное ПО информационных систем GraphicsMagick Group GraphicsMagick до 1.3.25 включительно | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 |

Наименование ОС и тип аппаратной платформы: openSUSE 132 | OpenSUSE Leap 421 | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 |
Дата выявления: 04.07.2017.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=44892734

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-updates/2016-10/msg00094.html
https://lists.opensuse.org/opensuse-updates/2016-10/msg00097.html

Для GraphicsMagick:
http://www.graphicsmagick.org/NEWS.html#july-4-2017

Для Debian GNU/Linux:
https://www.debian.org/security/2016/dsa-3746
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2016-7800.

Тип ошибки CWE: CWE-119, CWE-191
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://bugzilla.redhat.com/show_bug.cgi?id=1381148
https://wiki.astralinux.ru/pages/viewpage.action?pageId=44892734
https://lists.opensuse.org/opensuse-updates/2016-10/msg00094.html
https://lists.opensuse.org/opensuse-updates/2016-10/msg00097.html
https://sourceforge.net/p/graphicsmagick/code/ci/5c7b6d6094a25e99c57f8b18343914ebfd8213ef/
https://www.debian.org/security/2016/dsa-3746
https://nvd.nist.gov/vuln/detail/CVE-2016-7800
https://www.cvedetails.com/cve/CVE-2016-7800/
http://www.graphicsmagick.org/NEWS.html#july-4-2017

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *