Уязвимость BDU:2019-04099

Дата: 11.09.2017. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-04099.

Наименование уязвимости: Уязвимость реализации команды «INSERT … ON CONFLICT DO UPDATE» системы управления базами данных PostgreSQL, позволяющая нарушителю получить несанкционированный доступ к защищаемой информации.

Описание уязвимости: Уязвимость реализации команды «INSERT … ON CONFLICT DO UPDATE» системы управления базами данных PostgreSQL связана с отсутствием защиты служебных данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к защищаемой информации
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 9.0 | СУБД PostgreSQL Global Development Group PostgreSQL от 10.0 до 10.1 | СУБД PostgreSQL Global Development Group PostgreSQL от 9.6.0 до 9.6.6 | СУБД PostgreSQL Global Development Group PostgreSQL от 9.5.0 до 9.5.10 |

Наименование ОС и тип аппаратной платформы: Astra Linux 16 «Смоленск» | Debian GNU/Linux 90 |
Дата выявления: 11.09.2017.
CVSS 2.0: AV:N/AC:L/Au:S/C:C/I:N/A:N
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=44892734

Для PostgreSQL:
https://www.postgresql.org/about/news/1801/
https://www.postgresql.org/support/security/

Для Debian GNU/Linux:
https://www.debian.org/security/2017/dsa-4028
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2017-15099.

Тип ошибки CWE: CWE-200
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://wiki.astralinux.ru/pages/viewpage.action?pageId=44892734
https://www.postgresql.org/about/news/1801/
https://www.postgresql.org/support/security/
https://www.debian.org/security/2017/dsa-4028
https://nvd.nist.gov/vuln/detail/CVE-2017-15099
https://threats.kaspersky.com/ru/vulnerability/KLA11147/
https://postgrespro.ru/docs/postgrespro/10/release-10-1.html
https://www.cvedetails.com/cve/CVE-2017-15099/?q=CVE-2017-15099

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *