Уязвимость BDU:2019-04641

Дата: 06.05.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-04641.

Наименование уязвимости: Уязвимость системы управления базами данных PostgreSQL, связанная с некорректным контролем доступа, позволяющая нарушителю получить доступ к конфиденциальным данным.

Описание уязвимости: Уязвимость системы управления базами данных PostgreSQL связана с ошибкой политики безопасности, в которой значения столбцов, которые имеют привилегию SELECT, могут быть прочитаны. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, получить доступ к конфиденциальным данным
Уязвимое ПО: Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | СУБД PostgreSQL Global Development Group PostgreSQL от 11.0 до 11.3 | СУБД PostgreSQL Global Development Group PostgreSQL от 10.0 до 10.8 | СУБД PostgreSQL Global Development Group PostgreSQL от 9.5.0 до 9.5.17 | СУБД PostgreSQL Global Development Group PostgreSQL от 9.6.0 до 9.6.13 |

Наименование ОС и тип аппаратной платформы: Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | OpenSUSE Leap 150 | OpenSUSE Leap 151 |
Дата выявления: 06.05.2019.
CVSS 2.0: AV:N/AC:L/Au:S/C:P/I:N/A:N
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 4,3)

Возможные меры по устранению:
Использование рекомендаций:
Для PostgreSQL 11:
Обновление программного обеспечения до 11.5-1 или более поздней версии

Для PostgreSQL 9.4:
Обновление программного обеспечения до 9.4.24-0+deb8u1 или более поздней версии

Для PostgreSQL 9.6:
Обновление программного обеспечения до 9.6.15-0+deb9u1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета postgresql-11) до 11.5-1+deb10u1 или более поздней версии
Обновление программного обеспечения (пакета postgresql-9.4 ) до 9.4.24-0+deb8u1 или более поздней версии
Обновление программного обеспечения (пакета postgresql-9.6) до 9.6.13-0+deb9u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета postgresql-11) до 11.5-1+deb10u1 или более поздней версии
Обновление программного обеспечения (пакета postgresql-9.4 ) до 9.4.24-0+deb8u1 или более поздней версии
Обновление программного обеспечения (пакета postgresql-9.6) до 9.6.13-0+deb9u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2019-10130/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-10130.

Тип ошибки CWE: CWE-284
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2019-10130
https://security-tracker.debian.org/tracker/CVE-2019-10130
https://www.postgresql.org/about/news/1939/
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186
https://www.suse.com/security/cve/CVE-2019-10130/
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20201207SE16MD

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *