Уязвимость BDU:2019-04744

Дата: 29.07.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-04744.

Наименование уязвимости: Уязвимость драйверов drivers/bluetooth/hci_ath.c, drivers/bluetooth/hci_bcm.c, drivers/bluetooth/hci_intel.c, drivers/bluetooth/hci_ldisc.c, drivers/bluetooth/hci_mrvl.c, drivers/bluetooth/hci_qca.c, drivers/bluetooth/hci_uart.h для UART-подключаемых адаптеров Bluetooth ядра операционных систем Linux, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость драйверов drivers/bluetooth/hci_ath.c, drivers/bluetooth/hci_bcm.c, drivers/bluetooth/hci_intel.c, drivers/bluetooth/hci_ldisc.c, drivers/bluetooth/hci_mrvl.c, drivers/bluetooth/hci_qca.c, drivers/bluetooth/hci_uart.h для UART-подключаемых адаптеров Bluetooth ядра операционных систем Linux связана с разыменованием нулевого указателя. Эксплуатация уязвимости может позволить нарушителю вызвать отказ в обслуживании с помощью вызова функции ioctl
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система АО «ИВК» Альт Линукс СПТ 7.0 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 19.04 | Операционная система АО «ИВК» Альт 8 СП Сервер — | Операционная система АО «ИВК» Альт 8 СП Рабочая станция — | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Debian GNU/Linux 10.0 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Альт Линукс СПТ 70 | Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1904 | Альт 8 СП Сервер — | Альт 8 СП Рабочая станция — | Red Hat Enterprise Linux 8 | Debian GNU/Linux 100 |
Дата выявления: 29.07.2019.
CVSS 2.0: AV:L/AC:H/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 4,7)

Возможные меры по устранению:
Использование рекомендаций:
Для Альт Линукс СПТ:
https://cve.basealt.ru/otchet-po-obnovleniiam-ot-06082019.html

Для Альт 8 СП Сервер и Альт 8 СП Рабочая станция:
http://altsp.su/obnovleniya-bezopasnosti/

Для программных продуктов Red Hat Inc.:
https://bugzilla.redhat.com/show_bug.cgi?id=1733874

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2019-10207

Для Ubuntu:
https://usn.ubuntu.com/4115-1/
https://usn.ubuntu.com/4118-1/
https://usn.ubuntu.com/4145-1/
https://usn.ubuntu.com/4147-1/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-10207.

Тип ошибки CWE: CWE-476
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://cve.basealt.ru/otchet-po-obnovleniiam-ot-06082019.html
http://altsp.su/obnovleniya-bezopasnosti/
https://bugzilla.redhat.com/show_bug.cgi?id=1733874
https://security-tracker.debian.org/tracker/CVE-2019-10207
https://usn.ubuntu.com/usn/usn-4115-1
https://usn.ubuntu.com/usn/usn-4118-1
https://lore.kernel.org/linux-bluetooth/[email protected]/T/#u
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b36a1552d7319bbfd5cf7f08726c23c5c66d4f73
https://github.com/malaterre/linux/commit/b36a1552d7319bbfd5cf7f08726c23c5c66d4f73

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *