Уязвимость BDU:2019-04864

Дата: 13.11.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2019-04864.

Наименование уязвимости: Уязвимость компонента YARN NodeManager платформы для распределенной разработки и выполнения программ Apache Hadoop, позволяющая нарушителю обойти существующие ограничения безопасности и внедрить вредоносный код в zip-файл.

Описание уязвимости: Уязвимость компонента YARN NodeManager платформы для распределенной разработки и выполнения программ Apache Hadoop существует из-за неверного ограничения имени пути к каталогу с ограниченным доступом. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, обойти существующие ограничения безопасности и внедрить вредоносный код в zip-файл
Уязвимое ПО: Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 3.0.0-alpha1 | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 3.0.0-alpha2 | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop от 0.23.0 до 0.23.11 включительно | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop от 2.0.0 до 2.7.6 включительно | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 2.0.0-alpha | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop от 2.8.0 до 2.8.4 включительно | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop от 2.9.0 до 2.9.1 включительно | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop от 3.0.0 до 3.0.2 включительно | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 3.0.0-alpha3 | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 3.0.0-alpha4 | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 3.0.0-beta1 | Сетевое средство, Сетевое программное средство Apache Software Foundation Apache Hadoop 3.1.0 |

Наименование ОС и тип аппаратной платформы:
Дата выявления: 13.11.2018.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Использование рекомендаций:
https://hadoop.apache.org/cve_list.html#cve-2018-8009-http-cve-mitre-org-cgi-bin-cvename-cgi-name-cve-2018-8009-zip-slip-impact-on-apache-hadoop
https://lists.apache.org/thread.html/[email protected]%3Csolr-user.lucene.apache.org%3E
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-8009.

Тип ошибки CWE: CWE-22
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://cxsecurity.com/cveshow/CVE-2018-8009/
https://nvd.nist.gov/vuln/detail/CVE-2018-8009
https://hadoop.apache.org/cve_list.html#cve-2018-8009-http-cve-mitre-org-cgi-bin-cvename-cgi-name-cve-2018-8009-zip-slip-impact-on-apache-hadoop
https://lists.apache.org/thread.html/[email protected]%3Csolr-user.lucene.apache.org%3E

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *