Уязвимость BDU:2020-00684

Дата: 20.12.2016. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-00684.

Наименование уязвимости: Уязвимость скрипта pg_ctlcluster из пакета postgresql-common система управления базами данных PostgreSQL, позволяющая нарушителю получить несанкционированный доступ к конфиденциальным данным, вызвать отказ в обслуживании и оказать воздействие на целостность данных.

Описание уязвимости: Уязвимость скрипта pg_ctlcluster из пакета postgresql-common система управления базами данных PostgreSQL связана с неверным определением ссылки перед доступом к файлу. Эксплуатация уязвимости может позволить нарушителю получить несанкционированный доступ к конфиденциальным данным, вызвать отказ в обслуживании и оказать воздействие на целостность данных
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Canonical Ltd. Ubuntu 17.04 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 17.10 | Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | СУБД PostgreSQL Global Development Group PostgreSQL до 165+deb8u2 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Ubuntu 1704 | Ubuntu 1604 LTS | Ubuntu 1710 | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM |
Дата выявления: 20.12.2016.
CVSS 2.0: AV:L/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,2)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)

Возможные меры по устранению:
Использование рекомендаций:
Для postgresql-common:
Обновление программного обеспечения до 165+deb8u3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета postgresql-common) до 165+deb8u2 или более поздней версии

Для Ubuntu:
https://usn.ubuntu.com/3476-1/
https://usn.ubuntu.com/3476-2/

Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2016-1255.

Тип ошибки CWE: CWE-59
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2016-1255
https://security-tracker.debian.org/tracker/CVE-2016-1255
https://usn.ubuntu.com/3476-1/
https://usn.ubuntu.com/3476-2/
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *