Уязвимость BDU:2020-00699

Дата: 17.04.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-00699.

Наименование уязвимости: Уязвимость функции проверки сообщения в symfony/framework-bundle программной платформы для разработки и управления веб-приложениями Symfony, связанная с отсутствием мер по защите структур веб-страницы, позволяющая нарушителю произвести XSS-атаку.

Описание уязвимости: Уязвимость функции проверки сообщения в symfony/framework-bundle программной платформы для разработки и управления веб-приложениями Symfony связана с отсутствием мер по защите структур веб-страницы. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, произвести XSS-атаку
Уязвимое ПО: Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Прикладное ПО информационных систем SensioLabs, symfony community Symfony от 2.7.0 до 2.7.51 | Прикладное ПО информационных систем SensioLabs, symfony community Symfony от 2.8.0 до 2.8.50 | Прикладное ПО информационных систем SensioLabs, symfony community Symfony от 4.1.0 до 4.1.12 | Прикладное ПО информационных систем SensioLabs, symfony community Symfony от 4.2.0 до 4.2.7 | Прикладное ПО информационных систем SensioLabs, symfony community Symfony от 3.4.0 до 3.4.26 |

Наименование ОС и тип аппаратной платформы: Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 |
Дата выявления: 17.04.2019.
CVSS 2.0: AV:N/AC:M/Au:S/C:N/I:P/A:N
Уровень опасности уязвимости: Низкий уровень опасности (базовая оценка CVSS 2.0 составляет 3,5)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,2)

Возможные меры по устранению:
Использование рекомендаций:
Для symfony:
Обновление программного обеспечения до 3.4.22+dfsg-2 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета symfony) до 2.8.7+dfsg-1.3+deb9u2 или более поздней версии

Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-10909.

Тип ошибки CWE: CWE-79
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://symfony.com/blog/cve-2019-10909-escape-validation-messages-in-the-php-templating-engine
https://nvd.nist.gov/vuln/detail/CVE-2019-10909
https://security-tracker.debian.org/tracker/CVE-2019-10909
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *