Уязвимость BDU:2020-00717

Дата: 01.11.2018. Автор: CISO CLUB. Категории: Уязвимости

Идентификатор: BDU:2020-00717.

Наименование уязвимости: Уязвимость функции lsi_do_msgin эмулятора аппаратного обеспечения QEMU, связанная с чтением за границами буфера данных, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции lsi_do_msgin (hw/scsi/lsi53c895a.c) эмулятора аппаратного обеспечения QEMU связана с чтением за границами буфера данных. Эксплуатация уязвимости может позволить нарушителю вызвать отказ в обслуживании из-за недопустимого значения переменной msg_len

Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Novell Inc. OpenSUSE Leap 42.2 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Fedora Project Fedora 29 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | ПО виртуализации/ПО виртуального программно-аппаратного средства Фабрис Беллар QEMU до 3.1 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Ubuntu 1604 LTS | OpenSUSE Leap 422 | Ubuntu 1804 LTS | Ubuntu 1810 | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Fedora 29 | OpenSUSE Leap 150 |

Дата выявления: 01.11.2018.

CVSS 2.0: AV:L/AC:L/Au:N/C:N/I:N/A:P

Уровень опасности уязвимости: Низкий уровень опасности (базовая оценка CVSS 2.0 составляет 2,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)

Возможные меры по устранению:
Использование рекомендаций:
Для qemu:
Обновление программного обеспечения до 1:3.1+dfsg-8 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета qemu) до 1:2.8+dfsg-6+deb9u6 или более поздней версии

Для программных продуктов Novell Inc.
https://lists.opensuse.org/opensuse-security-announce/2018-12/msg00043.html
https://lists.opensuse.org/opensuse-security-announce/2018-12/msg00028.html
https://lists.opensuse.org/opensuse-security-announce/2018-12/msg00004.html

Для Ubuntu:
https://usn.ubuntu.com/3826-1/

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LQIBTGNRDQEXGAAYHE4JIWFAYFNHZ6QP/

Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186
.

Статус уязвимости: Подтверждена производителем

Наличие эксплойта: Данные уточняются

Информация об устранении: Уязвимость устранена

Идентификаторы других систем описаний уязвимости: CVE-2018-18849.

Тип ошибки CWE: CWE-125

Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2018-18849
https://security-tracker.debian.org/tracker/CVE-2018-18849
https://lists.opensuse.org/opensuse-security-announce/2018-12/msg00043.html
https://lists.opensuse.org/opensuse-security-announce/2018-12/msg00028.html
https://lists.opensuse.org/opensuse-security-announce/2018-12/msg00004.html
https://usn.ubuntu.com/3826-1/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LQIBTGNRDQEXGAAYHE4JIWFAYFNHZ6QP/

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Поделиться ссылкой

CISO CLUB

Об авторе CISO CLUB

Редакция портала cisoclub.ru. Добавляйте ваш материал на сайт в разделе "Разместить публикацию".
Читать все записи автора CISO CLUB

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *