Уязвимость BDU:2020-00729

Дата: 16.09.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-00729.

Наименование уязвимости: Уязвимость библиотеки LibTIFF, связанная с записью за границами буфера в памяти, позволяющая нарушителю вызвать отказ в обслуживании или выполнить произвольный код.

Описание уязвимости: Уязвимость библиотеки LibTIFF связана с записью за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании или выполнить произвольный код с помощью специально сформированного файла
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система ООО «РусБИТех-Астра» Astra Linux 1.6 «Смоленск» | Операционная система Silicon Graphics Corp. LibTIFF до 4.0.9 включительно | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Debian GNU/Linux 10.0 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Ubuntu 1810 | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM | Debian GNU/Linux 100 |
Дата выявления: 16.09.2018.
CVSS 2.0: AV:N/AC:M/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Использование рекомендаций:
Для tiff:
Обновление программного обеспечения до 4.0.3-12.3+deb8u10 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета tiff ) до 4.0.3-12.3+deb8u10 или более поздней версии

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/errata/RHSA-2019:2053

Для Ubuntu:
https://usn.ubuntu.com/3864-1/
https://usn.ubuntu.com/3906-2/

Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-17101.

Тип ошибки CWE: CWE-787
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2018-17101
https://security-tracker.debian.org/tracker/CVE-2018-17101
https://access.redhat.com/errata/RHSA-2019:2053
https://usn.ubuntu.com/3864-1/
https://usn.ubuntu.com/3906-2/
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *