Уязвимость BDU:2020-00742

Дата: 01.02.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-00742.

Наименование уязвимости: Уязвимость функции __zzip_fetch_disk_trailer библиотеки архивирования ZZIPlib, связанная с недостаточной проверкой вводимых данных, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции __zzip_fetch_disk_trailer библиотеки архивирования ZZIPlib связана с недостаточной проверкой вводимых данных. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании при помощи специального созданного zip-файла
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 17.10 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 | Прикладное ПО информационных систем Guido U. Draheim zziplib 0.13.67 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Ubuntu 1710 | Ubuntu 1804 LTS | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Debian GNU/Linux 100 |
Дата выявления: 01.02.2018.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для zziplib:
Обновление программного обеспечения до 0.13.62-3.2~deb9u1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета zziplib) до 0.13.62-3.2~deb9u1 или более поздней версии

Для Astra Linux:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/errata/RHSA-2019:2196

Для Ubuntu:
https://usn.ubuntu.com/3699-1/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-6541.

Тип ошибки CWE: CWE-20
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2018-6541
https://security-tracker.debian.org/tracker/CVE-2018-6541
https://github.com/gdraheim/zziplib/issues/16
https://wiki.astralinux.ru/pages/viewpage.action?pageId=57444186
https://access.redhat.com/errata/RHSA-2019:2196
https://usn.ubuntu.com/3699-1/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *