Уязвимость BDU:2020-01291

Дата: 22.12.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01291.

Наименование уязвимости: Уязвимость функции exif_read_data интерпретатора языка программирования PHP, позволяющая нарушителю раскрыть защищаемую информацию или вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции exif_read_data интерпретатора языка программирования PHP связана с использованием памяти после её освобождения. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, раскрыть защищаемую информацию или вызвать отказ в обслуживании
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.5 «Смоленск» | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Software Development Kit 12 SP4 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Canonical Ltd. Ubuntu 19.04 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Web Scripting 12 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for additional PackageHub 15 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Point of Sale 11 SP3 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Novell Inc. Suse Linux Enterprise Server 11 SP4-LTSS | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS | Операционная система Fedora Project Fedora 30 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Software Development Kit 12 SP5 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Web Scripting 15 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Web Scripting 15 SP1 | Операционная система Fedora Project Fedora 31 | Операционная система Canonical Ltd. Ubuntu 19.10 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition для «Эльбрус» 8.1 «Ленинград» | Прикладное ПО информационных систем PHP Group PHP от 7.2.0 до 7.2.26 включительно | Прикладное ПО информационных систем PHP Group PHP от 7.3.0 до 7.3.13 включительно | Прикладное ПО информационных систем PHP Group PHP 7.4.0 |

Наименование ОС и тип аппаратной платформы: Astra Linux Special Edition 15 «Смоленск» | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux Special Edition 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM | Ubuntu 1904 | OpenSUSE Leap 151 | Suse Linux Enterprise Server 11 SP4-LTSS | SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS | Fedora 30 | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Debian GNU/Linux 8 | Debian GNU/Linux 10 | Fedora 31 | Ubuntu 1910 | Astra Linux Special Edition для «Эльбрус» 81 «Ленинград» |
Дата выявления: 22.12.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для php7.0:
Обновление программного обеспечения до 7.0.33-0+deb9u6 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета php7.0) до 7.0.33-0+deb9u6или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета php7.0) до 7.0.33-0+deb9u6 или более поздней версии

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N7GCOAE6KVHYJ3UQ4KLPLTGSLX6IRVRN/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XWRQPYXVG43Q7DXMXH6UVWMKWGUW552F/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-11050.

Тип ошибки CWE: CWE-125, CWE-416
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N7GCOAE6KVHYJ3UQ4KLPLTGSLX6IRVRN/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XWRQPYXVG43Q7DXMXH6UVWMKWGUW552F/
https://bugs.php.net/bug.php?id=78793
https://nvd.nist.gov/vuln/detail/CVE-2019-11050
https://security-tracker.debian.org/tracker/CVE-2019-11050
https://bugs.php.net/bug.php?id=78793
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *