Уязвимость BDU:2020-01346

Дата: 06.10.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01346.

Наименование уязвимости: Уязвимость функции soup_ntlm_parse_challenge() библиотеки libsoup, позволяющая нарушителю оказать воздействие на целостность, конфиденциальность и доступность защищаемой информации.

Описание уязвимости: Уязвимость функции soup_ntlm_parse_challenge() библиотеки libsoup вызвана выходом операции за границы буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, оказать воздействие на целостность, конфиденциальность и доступность защищаемой информации
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 19.04 | Операционная система Debian GNU/Linux 10.0 | Сетевое программное средство libsoup от 2.65.1 до 2.66.4 | Сетевое программное средство libsoup от 2.67.1 до 2.68.1 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1904 | Debian GNU/Linux 100 |
Дата выявления: 06.10.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для libsoup:
https://gitlab.gnome.org/GNOME/libsoup/commit/f8a54ac85eec2008c85393f331cdd251af8266ad
https://gitlab.gnome.org/GNOME/libsoup/commit/88b7dff4467f4151afae244ea7d1223753cd05ab

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2019-17266

Для Ubuntu:
https://usn.ubuntu.com/4152-1/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-17266.

Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-17266.html?_ga=2.124475146.1895905037.1570426814-1618695258.1547637860
https://gitlab.gnome.org/GNOME/libsoup/commit/f8a54ac85eec2008c85393f331cdd251af8266ad
https://gitlab.gnome.org/GNOME/libsoup/commit/88b7dff4467f4151afae244ea7d1223753cd05ab
https://security-tracker.debian.org/tracker/CVE-2019-17266
https://usn.ubuntu.com/4152-1/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *