Уязвимость BDU:2020-01459

Дата: 15.12.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01459.

Наименование уязвимости: Уязвимость фреймворка для веб-приложений Django, связанная с ошибкой в работе механизма восстановления паролей, позволяющая нарушителю оказать воздействие на целостность данных.

Описание уязвимости: Уязвимость фреймворка для веб-приложений Django связана с некорректной проверкой электронного адреса после трансформации символов Юникода в регистр, что даёт возможность отправить токен сброса. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, оказать воздействие на целостность данных
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 19.04 | Операционная система Canonical Ltd. Ubuntu 19.10 | Операционная система АО «НПО РусБИТех» Astra Linux 8.1 «Ленинград» | Сетевое программное средство Django Software Foundation Django до 1.11.27 | Сетевое программное средство Django Software Foundation Django до 2.2.9 | Сетевое программное средство Django Software Foundation Django до 3.0.1 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1904 | Ubuntu 1910 | Astra Linux 81 «Ленинград» | Django до 11127 | Django до 229 | Django до 301 |
Дата выявления: 15.12.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:C/A:N
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Django:
Обновление программного обеспечения до 2:2.2.10-1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета python-django) до 1:1.11.28-1~deb10u1 или более поздней версии

Для Ubuntu:
https://usn.ubuntu.com/4224-1/

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/HCM2DPUI7TOZWN4A6JFQFUVQ2XGE7GUD/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-19844.

Тип ошибки CWE: CWE-640
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://nvd.nist.gov/vuln/detail/CVE-2019-19844
https://security-tracker.debian.org/tracker/CVE-2019-19844
https://wiki.astralinux.ru/pages/viewpage.action?pageId=71829652&src=sidebar
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://usn.ubuntu.com/4224-1/
https://www.debian.org/security/2020/dsa-4598
https://www.djangoproject.com/weblog/2019/dec/18/security-releases/
https://docs.djangoproject.com/en/dev/releases/security/
https://lists.fedoraproject.org/archives/list/[email protected]/message/HCM2DPUI7TOZWN4A6JFQFUVQ2XGE7GUD/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *