Уязвимость BDU:2020-01480

Дата: 07.10.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01480.

Наименование уязвимости: Уязвимость криптографической библиотеки Python ECDSA, связанная с недостаточной обработкой исключительных состояний, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость криптографической библиотеки Python ECDSA связана с недостаточной обработкой исключительных состояний. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Уязвимое ПО: Прикладное ПО информационных систем Novell Inc. SUSE Enterprise Storage 4 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud 7 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for additional PackageHub 15 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Прикладное ПО информационных систем Novell Inc. SUSE CaaS Platform 3.0 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Public Cloud 12 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Public Cloud 15 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud 8 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud Crowbar 8 | Прикладное ПО информационных систем Novell Inc. HPE Helion Openstack 8 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud 9 | Прикладное ПО информационных систем Novell Inc. SUSE Manager Server 3.2 | Прикладное ПО информационных систем, Программное средство защиты python-ECDSA до 0.13.3 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud Crowbar 9 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 80 | Debian GNU/Linux 90 | OpenSUSE Leap 150 | OpenSUSE Leap 151 |
Дата выявления: 07.10.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Python ECDSA:
Обновление криптографической библиотеки Python ECDSA до версии 0.13.3

Для Debian GNU/Linux:
https://www.debian.org/security/2019/dsa-4588

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2019-14853/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-14853.

Тип ошибки CWE: CWE-391, CWE-755
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/warner/python-ecdsa/releases/tag/python-ecdsa-0.13.3
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14853
https://www.debian.org/security/2019/dsa-4588
https://www.suse.com/security/cve/CVE-2019-14853/
https://nvd.nist.gov/vuln/detail/CVE-2019-14853
https://seclists.org/bugtraq/2019/Dec/33
https://security-tracker.debian.org/tracker/CVE-2019-14853

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *