Уязвимость BDU:2020-01748

Дата: 24.12.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01748.

Наименование уязвимости: Уязвимость функции zipfileUpdate() системы управления базами данных SQLite, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции zipfileUpdate() системы управления базами данных SQLite связана с некорректной обработкой NULL-пути при обновлении zip-архива. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Red Hat Inc. Red Hat Enterprise Linux Desktop 6.0 | Операционная система Red Hat Inc. Red Hat Enterprise Linux Server 6.0 | Операционная система Red Hat Inc. Red Hat Enterprise Linux Workstation 6.0 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Прикладное ПО информационных систем Novell Inc. SUSE Package Hub for SUSE Linux Enterprise 12 SP3 | Прикладное ПО информационных систем Novell Inc. SUSE Package Hub for SUSE Linux Enterprise 12 | Операционная система Canonical Ltd. Ubuntu 19.10 | Операционная система АО «НПО РусБИТех» Astra Linux 8.1 «Ленинград» | СУБД Hipp, Wyrick & Company, Inc. SQLite до 3.30.1 включительно |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux 16 «Смоленск» | Red Hat Enterprise Linux Desktop 60 | Red Hat Enterprise Linux Server 60 | Red Hat Enterprise Linux Workstation 60 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Red Hat Enterprise Linux 8 | OpenSUSE Leap 151 | Ubuntu 1910 | Astra Linux 81 «Ленинград» |
Дата выявления: 24.12.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для SQLite:
Обновление программного обеспечения до 3.31.1-3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета sqlite3) до 3.16.2-5+deb9u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета sqlite3) до 3.16.2-5+deb9u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00010.html
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00015.html
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00025.html

Для Ubuntu:
https://usn.ubuntu.com/4298-1/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2019-19925
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-19925.

Тип ошибки CWE: CWE-434
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00010.html
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00015.html
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00025.html
https://usn.ubuntu.com/4298-1/
https://access.redhat.com/security/cve/cve-2019-19925
https://nvd.nist.gov/vuln/detail/CVE-2019-19925
https://security-tracker.debian.org/tracker/CVE-2019-19925
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *