Уязвимость BDU:2020-01794

Дата: 15.07.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01794.

Наименование уязвимости: Уязвимость утилиты для применения изменений между разными версиями текстовых файлов GNU patch (inp.c и util.c), связанная с неправильным определением ссылки перед доступом к файлу, позволяющая нарушителю оказать воздействие на целостность данных.

Описание уязвимости: Уязвимость утилиты для применения изменений между разными версиями текстовых файлов GNU patch (inp.c и util.c) связана с неправильным определением ссылки перед доступом к файлу. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, оказать воздействие на целостность данных
Уязвимое ПО: Операционная система АО «НПО РусБИТех» Astra Linux 1.5 «Смоленск» | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Fedora Project Fedora 30 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система АО «НПО РусБИТех» Astra Linux 8.1 «Ленинград» | Прикладное ПО информационных систем GNU Patch до 2.7.6 включительно | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 |

Наименование ОС и тип аппаратной платформы: Astra Linux 15 «Смоленск» | Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Red Hat Enterprise Linux 8 | Fedora 30 | Ubuntu 1404 ESM | Astra Linux 81 «Ленинград» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Debian GNU/Linux 100 |
Дата выявления: 15.07.2019.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:C/A:N
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,9)

Возможные меры по устранению:
Использование рекомендаций:
Для GNU patch:
Обновление программного обеспечения до 2.7.6-5 или более поздней версии

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2019-13636
Обновление программного обеспечения (пакета patch) до 2.7.5-1+deb9u2 или более поздней версии

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/SVWWGISFWACROJJPVJJL4UBLVZ7LPOLT/

Для Ubuntu:
https://usn.ubuntu.com/4071-1/
https://usn.ubuntu.com/4071-2/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2019-13636
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-13636.

Тип ошибки CWE: CWE-59
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://lists.fedoraproject.org/archives/list/[email protected]/message/SVWWGISFWACROJJPVJJL4UBLVZ7LPOLT/
https://usn.ubuntu.com/4071-1/
https://usn.ubuntu.com/4071-2/
https://access.redhat.com/security/cve/CVE-2019-13636
https://git.savannah.gnu.org/cgit/patch.git/commit/?id=dce4683cbbe107a95f1f0d45fabc304acfb5d71a
https://nvd.nist.gov/vuln/detail/CVE-2019-13636
https://security-tracker.debian.org/tracker/CVE-2019-13636
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *