Уязвимость BDU:2020-01804

Дата: 14.05.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01804.

Наименование уязвимости: Уязвимость функции generate (src/werkzeug/debug/__init__.py) библиотеки веб-приложений Werkzeug, позволяющая нарушителю получить несанкционированный доступ к конфиденциальным данным.

Описание уязвимости: Уязвимость функции generate (src/werkzeug/debug/__init__.py) библиотеки веб-приложений Werkzeug связана с недостатком в энтропии в выборе PIN. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к конфиденциальным данным
Уязвимое ПО: Операционная система АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система АО «НПО РусБИТех» Astra Linux 8.1 «Ленинград» | Прикладное ПО информационных систем Werkzeug до 0.15.3 | ПО программно-аппаратного средства Red Hat Inc. Red Hat OpenStack Platform 15 (Stein) |

Наименование ОС и тип аппаратной платформы: Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | OpenSUSE Leap 150 | OpenSUSE Leap 151 | Astra Linux 81 «Ленинград» |
Дата выявления: 14.05.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:N/A:N
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для python-werkzeug:
Обновление программного обеспечения до 0.15.3 или более поздней версии

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2019-14806

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2019-09/msg00034.html
https://lists.opensuse.org/opensuse-security-announce/2019-09/msg00047.html

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2019-14806
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-14806.

Тип ошибки CWE: CWE-331
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/pallets/werkzeug/commit/00bc43b1672e662e5e3b8cecd79e67fc968fa246
https://lists.opensuse.org/opensuse-security-announce/2019-09/msg00034.html
https://lists.opensuse.org/opensuse-security-announce/2019-09/msg00047.html
https://access.redhat.com/security/cve/CVE-2019-14806
https://nvd.nist.gov/vuln/detail/CVE-2019-14806
https://security-tracker.debian.org/tracker/CVE-2019-14806
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *