Уязвимость BDU:2020-01847

Дата: 15.01.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01847.

Наименование уязвимости: Уязвимость функции fstream.DirWriter() пакета fstream, существующая из-за недостаточной проверки входных данных, позволяющая нарушителю перезаписать файлы в системе.

Описание уязвимости: Уязвимость функции fstream.DirWriter() пакета fstream существует из-за недостаточной проверки входных данных. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, перезаписать файлы в системе
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Прикладное ПО информационных систем Novell Inc. SUSE Enterprise Storage 4 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud 7 | Операционная система Canonical Ltd. Ubuntu 19.04 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Web Scripting 12 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Novell Inc. Suse Linux Enterprise Server 11 SP4-LTSS | Операционная система Novell Inc. SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Web Scripting 15 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Module for Web Scripting 15 SP1 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud Crowbar 8 | Прикладное ПО информационных систем Node.js Foundation fstream до 1.0.12 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud Crowbar 9 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1804 LTS | Ubuntu 1904 | OpenSUSE Leap 150 | OpenSUSE Leap 151 |
Дата выявления: 15.01.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:C/A:N
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для fstream:
https://github.com/npm/fstream/commit/6a77d2fa6e1462693cf8e46f930da96ec1b0bb22
https://www.npmjs.com/advisories/886

Для Ubuntu:
https://usn.ubuntu.com/4123-1/

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2019-13173/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-13173.

Тип ошибки CWE: CWE-20
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.suse.com/security/cve/CVE-2019-13173/
https://nvd.nist.gov/vuln/detail/CVE-2019-13173
https://usn.ubuntu.com/4123-1/
https://github.com/npm/fstream/commit/6a77d2fa6e1462693cf8e46f930da96ec1b0bb22
https://www.npmjs.com/advisories/886
https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00010.html
https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00052.html

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *