Уязвимость BDU:2020-01871

Дата: 23.08.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01871.

Наименование уязвимости: Уязвимость встроенного конвертера PDF14 набора программного обеспечения для обработки, преобразования и генерации документов Ghostscript, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость встроенного конвертера PDF14 набора программного обеспечения для обработки, преобразования и генерации документов Ghostscript связана с использованием памяти после ее освобождения. Эксплуатация уязвимости может позволить нарушителю вызвать отказ в обслуживании с помощью специально сформированного PostScript-файла
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Novell Inc. OpenSUSE Leap 42.3 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Прикладное ПО информационных систем Artifex Software Inc. Ghostscript до 9.24 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Novell Inc. OpenSUSE Leap 15.0 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | OpenSUSE Leap 423 | Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | OpenSUSE Leap 150 |
Дата выявления: 23.08.2018.
CVSS 2.0: AV:L/AC:M/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,9)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Ghostscript:
https://www.artifex.com/news/ghostscript-security-resolved/
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=c432131c3fdb2143e148e8ba88555f7f7a63b25e
https://bugs.ghostscript.com/show_bug.cgi?id=699661

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2018-16540/

Для Ubuntu:
https://usn.ubuntu.com/3768-1/

Для Debian GNU/Linux:
https://www.debian.org/security/2018/dsa-4288
https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2018-16540
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-16540.

Тип ошибки CWE: CWE-416
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=c432131c3fdb2143e148e8ba88555f7f7a63b25e
https://access.redhat.com/errata/RHBA-2019:0327
https://access.redhat.com/errata/RHSA-2019:0229
https://bugs.ghostscript.com/show_bug.cgi?id=699661
https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html
https://security.gentoo.org/glsa/201811-12
https://usn.ubuntu.com/3768-1/
https://www.artifex.com/news/ghostscript-security-resolved/
https://www.debian.org/security/2018/dsa-4288

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *