Уязвимость BDU:2020-01913

Дата: 31.03.2020. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-01913.

Наименование уязвимости: Уязвимость функции pamk5_prompter_krb5 (prompting.c) библиотеки libpam-krb5, связанная с недостатком механизма проверки размера копируемых данных, позволяющая нарушителю получить несанкционированный доступ к конфиденциальным данным, вызвать отказ в обслуживании или оказать воздействие на целостность данных.

Описание уязвимости: Уязвимость функции pamk5_prompter_krb5 (prompting.c) библиотеки libpam-krb5 связана с недостатком механизма проверки размера копируемых данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к конфиденциальным данным, вызвать отказ в обслуживании или оказать воздействие на целостность данных
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система ООО «РусБИТех-Астра» Astra Linux 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Canonical Ltd. Ubuntu 19.10 | Прикладное ПО информационных систем libpam-krb5 до 4.9 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Ubuntu 1910 |
Дата выявления: 31.03.2020.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для libpam-krb5:
Обновление программного обеспечения до 4.9 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета libpam-krb5) до 4.8-2+deb10u1 или более поздней версии

Для Ubuntu:
https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-10595.html

Для Astra Linux:
Обновление программного обеспечения (пакета libpam-krb5) до 4.8-2+deb10u1 или более поздней версии
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2020-10595.

Тип ошибки CWE: CWE-120
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://usn.ubuntu.com/4314-1/
https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-10595.html
https://github.com/rra/pam-krb5/commit/e7879e27a37119fad4faf133a9f70bdcdc75d760
https://nvd.nist.gov/vuln/detail/CVE-2020-10595
https://security-tracker.debian.org/tracker/CVE-2020-10595
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20201207SE16MD

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *