Уязвимость BDU:2020-02033

Дата: 08.04.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-02033.

Наименование уязвимости: Уязвимость функции EncodeImage графического редактора GraphicsMagick, связанная с чтением за допустимыми границами буфера данных, позволяющая нарушителю получить доступ к конфиденциальным данным, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции EncodeImage графического редактора GraphicsMagick связана с чтением за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, получить несанкционированный доступ к информации и нарушить ее целостность и доступность
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Debian GNU/Linux 10.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition для «Эльбрус» 8.1 «Ленинград» | Прикладное ПО информационных систем GraphicsMagick Group GraphicsMagick до 1.3.31 включительно |

Наименование ОС и тип аппаратной платформы: Astra Linux Special Edition 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | OpenSUSE Leap 151 | Debian GNU/Linux 100 | Astra Linux Special Edition для «Эльбрус» 81 «Ленинград» |
Дата выявления: 24.12.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,1)

Возможные меры по устранению:
Использование рекомендаций:
Для graphicsmagick:
Обновление программного обеспечения до .4~hg15978-1+deb10u1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета graphicsmagick) до .4~hg15978-1+deb10u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2020-01/msg00026.html
https://lists.opensuse.org/opensuse-security-announce/2020-01/msg00064.html

Для Astra Linux:
Использование рекомендаций производителя:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-19953.

Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/28f8bacd4bbf
https://lists.opensuse.org/opensuse-security-announce/2020-01/msg00026.html
https://lists.opensuse.org/opensuse-security-announce/2020-01/msg00064.html
https://nvd.nist.gov/vuln/detail/CVE-2019-19953
https://security-tracker.debian.org/tracker/CVE-2019-19953
https://sourceforge.net/p/graphicsmagick/bugs/617/
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210611SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *