Уязвимость BDU:2020-02037

Дата: 17.07.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-02037.

Наименование уязвимости: Уязвимость функции Application::runExternalProgram() located (app/application.cpp) кросс-платформенный BitTorrent клиента qBittorrent, связанная с недостатками принятых мер по чистке данных на управляющем уровне, позволяющая нарушителю получить несанкционированный доступ к конфиденциальным данным, вызвать отказ в обслуживании или оказать воздействие на целостность данных.

Описание уязвимости: Уязвимость функции Application::runExternalProgram() located (app/application.cpp) кросс-платформенный BitTorrent клиента qBittorrent связана с недостатками принятых мер по чистке данных на управляющем уровне. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к конфиденциальным данным, вызвать отказ в обслуживании или оказать воздействие на целостность данных
Уязвимое ПО: Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Fedora Project Fedora 29 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Fedora Project Fedora 30 | Операционная система Debian GNU/Linux 10.0 | Прикладное ПО информационных систем Christophe Dumez qBittorrent до 4.1.7 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 80 | Debian GNU/Linux 90 | Fedora 29 | OpenSUSE Leap 151 | Fedora 30 | Debian GNU/Linux 100 |
Дата выявления: 17.07.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для qbittorrent:
Обновление программного обеспечения до 4.1.7 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета qbittorrent) до 4.1.5-1+deb10u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00080.html
https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00085.html

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/5T4XAX2VUI4WMAS5AI4OE3OEQSQCDCF5/
https://lists.fedoraproject.org/archives/list/[email protected]/message/OH3WYCKODG4OKMC4S6PWHLHAWWU6ORNC/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-13640.

Тип ошибки CWE: CWE-77
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00080.html
https://lists.opensuse.org/opensuse-security-announce/2019-08/msg00085.html
https://lists.fedoraproject.org/archives/list/[email protected]/message/5T4XAX2VUI4WMAS5AI4OE3OEQSQCDCF5/
https://lists.fedoraproject.org/archives/list/[email protected]/message/OH3WYCKODG4OKMC4S6PWHLHAWWU6ORNC/
https://github.com/qbittorrent/qBittorrent/issues/10925
https://nvd.nist.gov/vuln/detail/CVE-2019-13640
https://security-tracker.debian.org/tracker/CVE-2019-13640
https://github.com/qbittorrent/qBittorrent/issues/10925

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *