Уязвимость BDU:2020-02393

Дата: 01.08.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-02393.

Наименование уязвимости: Уязвимость функции SplashOutputDev::tilingPatternFill (SplashOutputDev.cc) библиотеки для отображения PDF-файлов Poppler, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции SplashOutputDev::tilingPatternFill (SplashOutputDev.cc) библиотеки для отображения PDF-файлов Poppler связана с ошибками деления на ноль. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 19.04 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Fedora Project Fedora 30 | Операционная система Debian GNU/Linux 10.0 | Операционная система Fedora Project Fedora 31 | Прикладное ПО информационных систем Poppler до 0.78.0 включительно |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 7 | Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1904 | Red Hat Enterprise Linux 8 | Fedora 30 | Debian GNU/Linux 100 | Fedora 31 |
Дата выявления: 01.08.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Poppler:
https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/317
https://gitlab.freedesktop.org/poppler/poppler/-/issues/802

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2019-14494

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2019-14494

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/AHYAM32PALHQXL3O4DKIJ3EJB6AKBOVC/
https://lists.fedoraproject.org/archives/list/[email protected]/message/DLAQBLBIIL3A5XZQYR4MG3Z4LIPIC42P/

Для Ubuntu:
https://usn.ubuntu.com/4091-1/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-14494.

Тип ошибки CWE: CWE-369
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-14494.html?_ga=2.206646096.2109563961.1565586827-1618695258.1547637860
https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/317
https://gitlab.freedesktop.org/poppler/poppler/-/issues/802
https://security-tracker.debian.org/tracker/CVE-2019-14494
https://access.redhat.com/security/cve/CVE-2019-14494
https://lists.fedoraproject.org/archives/list/[email protected]/message/AHYAM32PALHQXL3O4DKIJ3EJB6AKBOVC/
https://lists.fedoraproject.org/archives/list/[email protected]/message/DLAQBLBIIL3A5XZQYR4MG3Z4LIPIC42P/
https://usn.ubuntu.com/4091-1/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *