Уязвимость BDU:2020-03214

Дата: 12.11.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-03214.

Наименование уязвимости: Уязвимость функции phar_parse_pharfile (xt/phar/phar.c) интерпретатора языка программирования PHP, позволяющая нарушителю получить несанкционированный доступ к защищаемой информации.

Описание уязвимости: Уязвимость функции phar_parse_pharfile (xt/phar/phar.c) интерпретатора языка программирования PHP связана с чтением за границами буфера. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к защищаемой информации
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Novell Inc. OpenSUSE Leap 42.3 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Прикладное ПО информационных систем PHP Group PHP от 7.0.0 до 7.0.33 | Прикладное ПО информационных систем PHP Group PHP до 5.6.39 | Прикладное ПО информационных систем PHP Group PHP от 7.1.0 до 7.1.25 | Прикладное ПО информационных систем PHP Group PHP от 7.2.0 до 7.2.13 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 7 | OpenSUSE Leap 423 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM | Red Hat Enterprise Linux 8 | OpenSUSE Leap 151 | Ubuntu 1404 ESM |
Дата выявления: 12.11.2018.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:N/A:N
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Php:
http://php.net/ChangeLog-5.php

Для программных продуктов Novell Inc.:
https://www.suse.com/support/update/announcement/2019/suse-su-201914013-1/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2018-20783

Для Ubuntu.:
https://security-tracker.debian.org/tracker/CVE-2018-20783
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-20783.

Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.suse.com/support/update/announcement/2019/suse-su-201914013-1/
https://access.redhat.com/security/cve/cve-2018-20783
https://nvd.nist.gov/vuln/detail/CVE-2018-20783
https://security-tracker.debian.org/tracker/CVE-2018-20783
http://php.net/ChangeLog-5.php

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *