Уязвимость BDU:2020-03949

Дата: 05.06.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-03949.

Наименование уязвимости: Уязвимость функции конструктора (designer/move.js file) веб-приложения для администрирования систем управления базами данных phpMyAdmin, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость функции конструктора (designer/move.js file) веб-приложения для администрирования систем управления базами данных phpMyAdmin связана с непринятием мер по защите структуры запроса SQL. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, выполнить произвольный код
Уязвимое ПО: Операционная система Novell Inc. OpenSUSE Leap 42.3 | Операционная система Fedora Project Fedora 29 | Операционная система Novell Inc. OpenSUSE Leap 15.0 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Fedora Project Fedora 30 | Прикладное ПО информационных систем Novell Inc. openSUSE Backports SLE-15 | Прикладное ПО информационных систем Novell Inc. openSUSE Backports SLE-15-SP1 | Сетевое программное средство phpMyAdmin Developer Team phpMyAdmin до 4.9.0.1 |

Наименование ОС и тип аппаратной платформы: OpenSUSE Leap 423 | Fedora 29 | OpenSUSE Leap 150 | OpenSUSE Leap 151 | Fedora 30 |
Дата выявления: 05.06.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для phpMyAdmin:
https://www.phpmyadmin.net/security/PMASA-2019-3/

Для программных продуктов Novell Inc.:
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00005.html
http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00017.html

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/II4HC4QO6WUL2IRSQKCB66UBJOLLI5OV/
https://lists.fedoraproject.org/archives/list/[email protected]/message/ZKJMYVXEDXGEGRO42T6H6VOEZJ65QPQ7/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-11768.

Тип ошибки CWE: CWE-89
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00005.html
http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00017.html
http://www.securityfocus.com/bid/108617
https://lists.fedoraproject.org/archives/list/[email protected]/message/II4HC4QO6WUL2IRSQKCB66UBJOLLI5OV/
https://lists.fedoraproject.org/archives/list/[email protected]/message/ZKJMYVXEDXGEGRO42T6H6VOEZJ65QPQ7/
https://www.phpmyadmin.net/security/PMASA-2019-3/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *