Уязвимость BDU:2020-03959

Дата: 06.04.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-03959.

Наименование уязвимости: Уязвимость компонента libvncclient/sockets.c кроссплатформенной библиотеки LibVNCServer, позволяющая нарушителю вызвать отказ в обслуживании или выполнить произвольный код.

Описание уязвимости: Уязвимость компонента libvncclient/sockets.c кроссплатформенной библиотеки LibVNCServer связана с выходом операции за границы буфера. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании или выполнить произвольный код с помощью специально созданного имени сокета
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Debian GNU/Linux 8 | Операционная система Fedora Project Fedora 31 | Операционная система Fedora Project Fedora 32 | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Прикладное ПО информационных систем LibVNCServer до 0.9.13 | Операционная система Novell Inc. OpenSUSE Leap 15.2 |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Red Hat Enterprise Linux 8 | OpenSUSE Leap 151 | Debian GNU/Linux 8 | Fedora 31 | Fedora 32 | Ubuntu 2004 LTS | OpenSUSE Leap 152 |
Дата выявления: 06.04.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для LibVNCServer:
https://github.com/LibVNC/libvncserver/commit/3fd03977c9b35800d73a865f167338cb4d05b0c1
https://github.com/LibVNC/libvncserver/compare/LibVNCServer-0.9.12…LibVNCServer-0.9.13

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2019-20839

Для Ubuntu:
https://usn.ubuntu.com/4434-1/

Для Debian GNU/Linux:
https://lists.debian.org/debian-lts-announce/2020/06/msg00035.html

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/4F6FUH4EFK4NAP6GT4TQRTBKWIRCZLIY/
https://lists.fedoraproject.org/archives/list/[email protected]/message/NVP7TJVYJDXDFRHVQ3ENEN3H354QPXEZ/

Для программных продуктов Novell Inc.:
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00033.html
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00055.html
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00066.html
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2017-18922.

Тип ошибки CWE: CWE-120
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00033.html
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00055.html
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00066.html
https://github.com/LibVNC/libvncserver/commit/3fd03977c9b35800d73a865f167338cb4d05b0c1
https://github.com/LibVNC/libvncserver/compare/LibVNCServer-0.9.12…LibVNCServer-0.9.13
https://lists.debian.org/debian-lts-announce/2020/06/msg00035.html
https://lists.fedoraproject.org/archives/list/[email protected]/message/4F6FUH4EFK4NAP6GT4TQRTBKWIRCZLIY/
https://lists.fedoraproject.org/archives/list/[email protected]/message/NVP7TJVYJDXDFRHVQ3ENEN3H354QPXEZ/
https://usn.ubuntu.com/4434-1/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *