Уязвимость BDU:2020-05465

Дата: 12.11.2020. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-05465.

Наименование уязвимости: Уязвимость компонента core server системы управления базами данных PostgreSQL, позволяющая нарушителю оказать влияние на целостность, доступность и конфиденциальность данных.

Описание уязвимости: Уязвимость компонента core server системы управления базами данных PostgreSQL связана с недостаточной защитой структуры запроса SQL. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, оказать влияние на целостность, доступность и конфиденциальность данных
Уязвимое ПО: Операционная система Debian GNU/Linux 9 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система ООО «Ред Софт» РЕД ОС 7.2 Муром | Прикладное ПО информационных систем Red Hat Inc. Red Hat Software Collections — | СУБД PostgreSQL Global Development Group PostgreSQL до 9.5.24 | СУБД PostgreSQL Global Development Group PostgreSQL от 9.6.0 до 9.6.20 | СУБД PostgreSQL Global Development Group PostgreSQL от 10.0 до 10.15 | СУБД PostgreSQL Global Development Group PostgreSQL от 11.0 до 11.10 | СУБД PostgreSQL Global Development Group PostgreSQL от 12.0 до 12.5 | СУБД PostgreSQL Global Development Group PostgreSQL от 13.0 до 13.1 | Операционная система ООО «РусБИТех-Астра» Astra Linux 2.12 «Орел» |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 9 | Red Hat Enterprise Linux 8 | РЕД ОС 72 Муром | Astra Linux 212 «Орел» |
Дата выявления: 12.11.2020.
CVSS 2.0: AV:N/AC:L/Au:S/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Использование рекомендаций:
Для PostgreSQL:
https://www.postgresql.org/support/security/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2020-25695

Для Debian GNU/Linux:
https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html

Для Astra Linux:
Обновление программного обеспечения (пакета postgresql-9.6) до 9.6.20-0+deb9u1 или более поздней версии

При невозможности выполнить обновление в качестве обходного пути можно отключить autovacuum и не запускать вручную операции ANALYZE, CLUSTER, REINDEX, CREATE INDEX, VACUUM FULL и REFRESH MATERIALIZED VIEW, а также не выполнять восстановление БД на основе вывода команды pg_dump.
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2020-25695.

Тип ошибки CWE: CWE-89
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://access.redhat.com/security/cve/cve-2020-25695
https://www.postgresql.org/support/security/
https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *