Уязвимость BDU:2020-05769

Дата: 26.12.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-05769.

Наименование уязвимости: Уязвимость функции mbfl_filt_conv_big5_wchar интерпретатора PHP, позволяющая нарушителю получить доступ к защищаемой информации или вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции mbfl_filt_conv_big5_wchar интерпретатора PHP вызвана выходом операции за границы буфера. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, получить доступ к защищаемой информации или вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Debian GNU/Linux 9 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Debian GNU/Linux 8 | Операционная система Debian GNU/Linux 10 | Операционная система Canonical Ltd. Ubuntu 19.10 | Прикладное ПО информационных систем PHP Group PHP от 7.2.0 до 7.2.27 | Прикладное ПО информационных систем PHP Group PHP от 7.3.0 до 7.3.14 | Прикладное ПО информационных систем PHP Group PHP от 7.4.0 до 7.4.2 | ПО сетевого программно-аппаратного средства Oracle Corp. Communications Diameter Signaling Router от 8.0 до 8.4 включительно |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS | Debian GNU/Linux 9 | Ubuntu 1804 LTS | OpenSUSE Leap 151 | Ubuntu 1404 ESM | Debian GNU/Linux 8 | Debian GNU/Linux 10 | Ubuntu 1910 |
Дата выявления: 26.12.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:

https://bugs.php.net/bug.php?id=79037

Для Debian:

https://www.debian.org/security/2020/dsa-4626

https://www.debian.org/security/2020/dsa-4628

https://lists.debian.org/debian-lts-announce/2020/02/msg00030.html



Для Ubuntu:

https://usn.ubuntu.com/4279-1/



Для openSUSE:

http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html



Для Oracle:

https://www.oracle.com/security-alerts/cpujul2020.html.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2020-7060.

Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.debian.org/security/2020/dsa-4626

https://www.debian.org/security/2020/dsa-4628

https://lists.debian.org/debian-lts-announce/2020/02/msg00030.html


https://usn.ubuntu.com/4279-1/


http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html
https://bugs.php.net/bug.php?id=79037
https://www.oracle.com/security-alerts/cpujul2020.html

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *