Уязвимость BDU:2020-05805

Дата: 28.07.2020. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2020-05805.

Наименование уязвимости: Уязвимость функции xgmac_enet_send из hw/net/xgmac.c эмулятора аппаратного обеспечения QEMU, связанная с недостатком механизма проверки размера копируемых данных, позволяющая нарушителю получить доступ к защищаемой информации, нарушить её целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции xgmac_enet_send из hw/net/xgmac.c эмулятора аппаратного обеспечения QEMU связана с недостатком механизма проверки размера копируемых данных. Эксплуатация уязвимости может позволить нарушителю получить доступ к защищаемой информации, нарушить её целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux 1.5 «Смоленск» | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Операционная система Novell Inc. OpenSUSE Leap 15.2 | ПО виртуализации/ПО виртуального программно-аппаратного средства Фабрис Беллар QEMU до 5.0.0 включительно | Операционная система ООО «РусБИТех-Астра» Astra Linux 2.12 «Орел» |

Наименование ОС и тип аппаратной платформы: Astra Linux 15 «Смоленск» | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Debian GNU/Linux 100 | Ubuntu 2004 LTS | OpenSUSE Leap 152 | Astra Linux 212 «Орел» |
Дата выявления: 28.07.2020.
CVSS 2.0: AV:L/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,2)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,6)

Возможные меры по устранению:
Использование рекомендаций:
Для Qemu:
Обновление программного обеспечения до 4.3.1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета qemu) до 1:3.1+dfsg-8+deb10u6 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета qemu) до 1:3.1+dfsg-8+deb10u8 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4467-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2020-15863.

Тип ошибки CWE: CWE-120
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://git.qemu.org/?p=qemu.git;a=commitdiff;h=5519724a13664b43e225ca05351c60b4468e4555
https://nvd.nist.gov/vuln/detail/CVE-2020-15863
https://security-tracker.debian.org/tracker/CVE-2020-15863
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15
https://ubuntu.com/security/notices/USN-4467-1
https://www.suse.com/security/cve/CVE-2020-15863/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *