Уязвимость BDU:2021-00098

Дата: 27.02.2020. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-00098.

Наименование уязвимости: Уязвимость интерпретатора языка программирования PHP, связанная с разыменованием нулевого указателя, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость интерпретатора языка программирования PHP связана с разыменованием нулевого указателя. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.5 «Смоленск» | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 12.04 ESM | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Canonical Ltd. Ubuntu 19.10 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition для «Эльбрус» 8.1 «Ленинград» | Прикладное ПО информационных систем PHP Group PHP от 7.2.0 до 7.2.27 | Прикладное ПО информационных систем PHP Group PHP от 7.3.0 до 7.3.14 | Прикладное ПО информационных систем PHP Group PHP от 7.4.0 до 7.4.2 |

Наименование ОС и тип аппаратной платформы: Astra Linux Special Edition 15 «Смоленск» 64-bit | Astra Linux Special Edition 15 «Смоленск» | Astra Linux Special Edition 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1204 ESM | OpenSUSE Leap 151 | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Ubuntu 1910 | Astra Linux Special Edition для «Эльбрус» 81 «Ленинград» |
Дата выявления: 17.02.2020.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)

Возможные меры по устранению:
Использование рекомендаций:
Для PHP:
Обновление программного обеспечения до 7.4.5-1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета php7.3) до 7.3.19-1~deb10u1 или более поздней версии
https://www.debian.org/security/2020/dsa-4717
https://www.debian.org/security/2020/dsa-4719
https://lists.debian.org/debian-lts-announce/2020/03/msg00034.html

Для Ubuntu:
https://usn.ubuntu.com/4330-1/

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81

Для программных продуктов Novell Inc/:
http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2020-7062.

Тип ошибки CWE: CWE-476
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html
https://bugs.php.net/bug.php?id=79221
https://lists.debian.org/debian-lts-announce/2020/03/msg00034.html
https://nvd.nist.gov/vuln/detail/CVE-2020-7062
https://security.gentoo.org/glsa/202003-57
https://security-tracker.debian.org/tracker/CVE-2020-7062
https://usn.ubuntu.com/4330-1/
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210611SE16
https://www.debian.org/security/2020/dsa-4717
https://www.debian.org/security/2020/dsa-4719
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *