Уязвимость BDU:2021-00123

Дата: 02.02.2020. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-00123.

Наименование уязвимости: Уязвимость множества функций из xml.rs библиотеки отрисовки векторной графики librsvg, связанная с ошибкой механизма контроля расходуемых ресурсов, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость множества функций из xml.rs библиотеки отрисовки векторной графики librsvg связана с ошибкой механизма контроля расходуемых ресурсов. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux 1.5 «Смоленск» | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Fedora Project Fedora 30 | Операционная система Debian GNU/Linux 10.0 | Операционная система Fedora Project Fedora 31 | Прикладное ПО информационных систем librsvg до 2.46.2 | Операционная система ООО «РусБИТех-Астра» Astra Linux 2.12 «Орел» |

Наименование ОС и тип аппаратной платформы: Astra Linux 15 «Смоленск» | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | OpenSUSE Leap 151 | Fedora 30 | Debian GNU/Linux 100 | Fedora 31 | Astra Linux 212 «Орел» |
Дата выявления: 02.02.2020.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для librsvg:
Обновление программного обеспечения до 2.46.2 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета librsvg) до 2.40.21-0+deb9u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета librsvg) до 2.40.21-0+deb9u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2020-03/msg00024.html

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/6IOHSO6BUKC6I66J5PZOMAGFVJ66ZS57/
https://lists.fedoraproject.org/archives/list/[email protected]/message/X3B5RWJQD5LA45MYLLR55KZJOJ5NVZGP/

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4436-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-20446.

Тип ошибки CWE: CWE-400
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://lists.opensuse.org/opensuse-security-announce/2020-03/msg00024.html
https://lists.fedoraproject.org/archives/list/[email protected]/message/6IOHSO6BUKC6I66J5PZOMAGFVJ66ZS57/
https://lists.fedoraproject.org/archives/list/[email protected]/message/X3B5RWJQD5LA45MYLLR55KZJOJ5NVZGP/
https://ubuntu.com/security/notices/USN-4436-1
https://gitlab.gnome.org/GNOME/librsvg/issues/515
https://nvd.nist.gov/vuln/detail/CVE-2019-20446
https://security-tracker.debian.org/tracker/CVE-2019-20446
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *