Уязвимость BDU:2021-00683

Дата: 29.01.2017. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-00683.

Наименование уязвимости: Уязвимость функции WP_Query (wp-includes/class-wp-query.php) системы управления содержимым сайта WordPress, позволяющая нарушителю выполнить произвольные SQL команды.

Описание уязвимости: Уязвимость функции WP_Query (wp-includes/class-wp-query.php) системы управления содержимым сайта WordPress связана с непринятием мер по защите структуры запроса SQL. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, выполнить произвольные SQL команды
Уязвимое ПО: Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Прикладное ПО информационных систем Oracle Corp. Oracle Data Integrator 12.2.1.3.0 | Прикладное ПО информационных систем Oracle Corp. Oracle Data Integrator 12.2.1.4.0 | Прикладное ПО информационных систем WordPress Foundation WordPress до 4.7.1 включительно | Прикладное ПО информационных систем Oracle Corp. Oracle Data Integrator 11.1.1.9.0 |

Наименование ОС и тип аппаратной платформы: Debian GNU/Linux 80 | Debian GNU/Linux 90 |
Дата выявления: 29.01.2017.
CVSS 2.0: AV:N/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для WordPress:
https://codex.wordpress.org/Version_4.7.2

Для программных продуктов Oracle Corp.:
https://www.oracle.com/security-alerts/cpujan2021.html

Для Debian GNU/Linux:
https://www.debian.org/security/2017/dsa-3779
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2017-5611.

Тип ошибки CWE: CWE-89
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://www.debian.org/security/2017/dsa-3779
http://www.openwall.com/lists/oss-security/2017/01/28/5
http://www.securityfocus.com/bid/95816
http://www.securitytracker.com/id/1037731
https://codex.wordpress.org/Version_4.7.2
https://github.com/WordPress/WordPress/commit/85384297a60900004e27e417eac56d24267054cb

WordPress 4.7.2 Security Release


https://wpvulndb.com/vulnerabilities/8730
https://www.oracle.com/security-alerts/cpujan2021.html

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *