Уязвимость BDU:2021-01008

Дата: 30.12.2020. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01008.

Наименование уязвимости: Уязвимость программной библиотеки Nokogiri, связанная с неверным ограничением XML-ссылок на внешние объекты, позволяющая нарушителю провести SSRF-атаку или XXE-атаку.

Описание уязвимости: Уязвимость программной библиотеки Nokogiri связана с неверным ограничением XML-ссылок на внешние объекты. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, провести SSRF-атаку или XXE-атаку
Уязвимое ПО: Операционная система Novell Inc. OpenSUSE Leap 15.2 | Прикладное ПО информационных систем Nokogiri до 1.11.0.rc4 |

Наименование ОС и тип аппаратной платформы: OpenSUSE Leap 152 |
Дата выявления: 30.12.2020.
CVSS 2.0: AV:N/AC:L/Au:S/C:P/I:N/A:N
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 4,3)

Возможные меры по устранению:
Использование рекомендаций:
Для Nokogiri:
https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-vr8q-g5c7-m54m

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2020-26247/
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2020-26247.

Тип ошибки CWE: CWE-611
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://www.suse.com/security/cve/CVE-2020-26247/
https://nvd.nist.gov/vuln/detail/CVE-2020-26247
https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-vr8q-g5c7-m54m

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *