Уязвимость BDU:2021-01283

Дата: 25.12.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01283.

Наименование уязвимости: Уязвимость функции Xref::getEntry библиотеки для рендеринга PDF-файлов Poppler, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции Xref::getEntry (XRef.cc) библиотеки для рендеринга PDF-файлов Poppler связана с разыменованием нулевого указателя. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система АО «НПО РусБИТех» Astra Linux 2.12 «Орел» | Прикладное ПО информационных систем Poppler до 0.72.0 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS 32-bit | Ubuntu 1804 LTS | Ubuntu 1810 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Astra Linux 212 «Орел» |
Дата выявления: 25.12.2018.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Poppler:
https://gitlab.freedesktop.org/poppler/poppler/issues/692
https://gitlab.freedesktop.org/poppler/poppler/merge_requests/143

Для Debian:
Обновление программного обеспечения (пакета poppler) до 0.48.0-2+deb9u3 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета poppler) до 0.48.0-2+deb9u3 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-3865-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-20481.

Тип ошибки CWE: CWE-476
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://gitlab.freedesktop.org/poppler/poppler/issues/692
https://gitlab.freedesktop.org/poppler/poppler/merge_requests/143
https://nvd.nist.gov/vuln/detail/CVE-2018-20481
https://security-tracker.debian.org/tracker/CVE-2018-20481
https://ubuntu.com/security/notices/USN-3865-1

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *