Уязвимость BDU:2021-01302

Дата: 29.10.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01302.

Наименование уязвимости: Уязвимость функции HandleZlibBPP реализации VNC с расширениями для оптимизации работы в условиях медленных каналов передачи данных Tightvnc, связанная с разыменованием нулевого указателя, позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции HandleZlibBPP реализации VNC с расширениями для оптимизации работы в условиях медленных каналов передачи данных Tightvnc связана с разыменованием нулевого указателя. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Canonical Ltd. Ubuntu 19.04 | Операционная система Debian GNU/Linux 10.0 | Операционная система АО «НПО РусБИТех» Astra Linux 2.12 «Орел» | Прикладное ПО информационных систем TightVNC до 1.3.10 включительно |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS 32-bit | Ubuntu 1804 LTS | Ubuntu 1810 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Ubuntu 1904 | Debian GNU/Linux 100 | Astra Linux 212 «Орел» |
Дата выявления: 29.10.2019.
CVSS 2.0: AV:N/AC:L/Au:N/C:N/I:N/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)

Возможные меры по устранению:
Использование рекомендаций:
Для Tightvnc:
Обновление программного обеспечения до 1:1.3.10-1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета tightvnc) до 1:1.3.9-9deb10u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета tightvnc) до 1:1.3.9-9deb10u1 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4407-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-15680.

Тип ошибки CWE: CWE-476
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://cert-portal.siemens.com/productcert/pdf/ssa-478893.pdf
https://lists.debian.org/debian-lts-announce/2019/12/msg00028.html
https://nvd.nist.gov/vuln/detail/CVE-2019-15680
https://security-tracker.debian.org/tracker/CVE-2019-15680
https://us-cert.cisa.gov/ics/advisories/icsa-20-343-08
https://usn.ubuntu.com/4407-1/

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *