Уязвимость BDU:2021-01304

Дата: 05.04.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01304.

Наименование уязвимости: Уязвимость функции Splash::blitTransparent библиотеки для рендеринга PDF-файлов Poppler, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции Splash::blitTransparent (splash/Splash.cc) библиотеки для рендеринга PDF-файлов Poppler связана с чтением за допустимыми границами буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Fedora Project Fedora 29 | Операционная система Canonical Ltd. Ubuntu 19.04 | Операционная система Fedora Project Fedora 30 | Операционная система Debian GNU/Linux 10.0 | Операционная система АО «НПО РусБИТех» Astra Linux 2.12 «Орел» | Прикладное ПО информационных систем Poppler до 0.74.0 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS 32-bit | Ubuntu 1804 LTS | Ubuntu 1810 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Fedora 29 | Ubuntu 1904 | Fedora 30 | Debian GNU/Linux 100 | Astra Linux 212 «Орел» |
Дата выявления: 05.04.2019.
CVSS 2.0: AV:N/AC:M/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Plopper:
Обновление программного обеспечения до 20.09.0-2 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета poppler) до 0.48.0-2+deb9u3 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета poppler) до 0.48.0-2+deb9u3 или более поздней версии

Для Fedora:
https://lists.fedoraproject.org/archives/list/[email protected]/message/7MAWV24KRXTFODLVT46RXI27XIQFX2QR/
https://lists.fedoraproject.org/archives/list/[email protected]/message/YWS7NVFFCUY3YSTMEKZEJEU6JVUUBKHB/

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4042-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-10872.

Тип ошибки CWE: CWE-125
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://gitlab.freedesktop.org/poppler/poppler/issues/750
https://lists.fedoraproject.org/archives/list/[email protected]/message/7MAWV24KRXTFODLVT46RXI27XIQFX2QR/
https://lists.fedoraproject.org/archives/list/[email protected]/message/YWS7NVFFCUY3YSTMEKZEJEU6JVUUBKHB/
https://nvd.nist.gov/vuln/detail/CVE-2019-10872
https://security-tracker.debian.org/tracker/CVE-2019-10872
https://ubuntu.com/security/notices/USN-4042-1

ФСТЭК России

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *