Уязвимость BDU:2021-01384

Дата: 28.10.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01384.

Наименование уязвимости: Уязвимость функции default_add_message файла read-catalog.c библиотеки проекта GNU для интернационализации Gettext, связанная с повторным освобождением области памяти, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции default_add_message файла read-catalog.c библиотеки проекта GNU для интернационализации Gettext связана с повторным освобождением области памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 12.04 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.10 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Прикладное ПО информационных систем gettext 0.19.8 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1204 32-bit | Ubuntu 1604 LTS 32-bit | Ubuntu 1804 LTS | Ubuntu 1810 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Astra Linux Common Edition 212 «Орёл» | Debian GNU/Linux 100 | Ubuntu 1404 ESM |
Дата выявления: 28.10.2018.
CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Gettext:
Обновление программного обеспечения до 0.21-3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета gettext) до 0.19.8.1-9 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета gettext) до 0.19.8.1-9 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-3815-1
https://ubuntu.com/security/notices/USN-3815-2
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-18751.

Тип ошибки CWE: CWE-415
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/CCCCCrash/POCs/tree/master/Bin/Tools-gettext-0.19.8.1/doublefree
https://github.com/CCCCCrash/POCs/tree/master/Bin/Tools-gettext-0.19.8.1/heapcorruption
https://nvd.nist.gov/vuln/detail/CVE-2018-18751
https://security-tracker.debian.org/tracker/CVE-2018-18751
https://ubuntu.com/security/notices/USN-3815-1
https://ubuntu.com/security/notices/USN-3815-2

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.