Уязвимость BDU:2021-01389

Дата: 13.04.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01389.

Наименование уязвимости: Уязвимость функции finish_stab файла stabs.c набора средств разработки программ Binutils, связанная с выходом операции за допустимые границы буфера данных, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции finish_stab файла stabs.c набора средств разработки программ Binutils связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Прикладное ПО информационных систем GNU General Public License GNU Binutils 2.30 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» | Операционная система Debian GNU/Linux 10.0 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Astra Linux Common Edition 212 «Орёл» | Debian GNU/Linux 100 |
Дата выявления: 13.04.2018.
CVSS 2.0: AV:N/AC:L/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Binutils:
Обновление программного обеспечения до 2.35.1-7 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета binutils) до 2.35.1-7 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета binutils) до 2.35.1-7 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4336-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-12699.

Тип ошибки CWE: CWE-787
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://bugs.launchpad.net/ubuntu/+source/binutils/+bug/1763102
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85454
https://nvd.nist.gov/vuln/detail/CVE-2018-12699
https://security-tracker.debian.org/tracker/CVE-2018-12699
https://sourceware.org/bugzilla/show_bug.cgi?id=23057
https://ubuntu.com/security/notices/USN-4336-1

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.