Уязвимость BDU:2021-01413

Дата: 26.12.2019. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01413.

Наименование уязвимости: Уязвимость декодера CopyRectDecoder программного обеспечения VNC TigerVNC, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость декодера CopyRectDecoder программного обеспечения VNC TigerVNC связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» | Операционная система Novell Inc. OpenSUSE Leap 15.1 | Операционная система Debian GNU/Linux 10.0 | Прикладное ПО информационных систем TigerVNC developers TigerVNC до 1.10.1 |

Наименование ОС и тип аппаратной платформы: Astra Linux Special Edition 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Astra Linux Common Edition 212 «Орёл» | OpenSUSE Leap 151 | Debian GNU/Linux 100 |
Дата выявления: 26.12.2019.
CVSS 2.0: AV:N/AC:L/Au:S/C:P/I:P/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,2)

Возможные меры по устранению:
Использование рекомендаций:
Для TigerVNC:
Обновление программного обеспечения до 1.10.1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета tigervnc) до 1.9.0+dfsg-3+deb10u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета tigervnc) до 1.9.0+dfsg-3+deb10u1 или более поздней версии
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2020-01/msg00039.html
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2019-15692.

Тип ошибки CWE: CWE-787
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/CendioOssman/tigervnc/commit/996356b6c65ca165ee1ea46a571c32a1dc3c3821
https://github.com/TigerVNC/tigervnc/releases/tag/v1.10.1
https://lists.opensuse.org/opensuse-security-announce/2020-01/msg00039.html
https://nvd.nist.gov/vuln/detail/CVE-2019-15692
https://security-tracker.debian.org/tracker/CVE-2019-15692
https://www.openwall.com/lists/oss-security/2019/12/20/2
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.