Уязвимость BDU:2021-01416

Дата: 07.10.2018. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01416.

Наименование уязвимости: Уязвимость подсистемы виртуализации Kernel-based Virtual Machine (KVM) в файле arch/arm64/kvm/guest.c ядра операционной системы Linux, позволяющая нарушителю нарушить целостность данных, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость подсистемы виртуализации Kernel-based Virtual Machine (KVM) в файле arch/arm64/kvm/guest.c ядра операционной системы Linux связана с недостатком механизма проверки вводимых данных. Эксплуатация уязвимости может позволить нарушителю нарушить целостность данных, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 12.04 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Linux до 4.18.12 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1204 32-bit | Ubuntu 1604 LTS 32-bit | Ubuntu 1804 LTS | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Astra Linux Common Edition 212 «Орёл» | Debian GNU/Linux 100 | Ubuntu 1404 ESM | Linux до 41812 |
Дата выявления: 07.10.2018.
CVSS 2.0: AV:L/AC:L/Au:N/C:N/I:P/A:P
Уровень опасности уязвимости: Низкий уровень опасности (базовая оценка CVSS 2.0 составляет 3,6)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,1)

Возможные меры по устранению:
Использование рекомендаций:
Для Linux:
Обновление программного обеспечения до 4.9.110-3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета linux-4.9) до 4.9.110-3+deb9u5~deb8u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета linux-4.9) до 4.9.110-3+deb9u5~deb8u1 или более поздней версии

Для Ubuntu:
https://usn.ubuntu.com/3821-1/
https://usn.ubuntu.com/3821-2/
https://usn.ubuntu.com/3931-1/
https://usn.ubuntu.com/3931-2
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-18021.

Тип ошибки CWE: CWE-20
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2a3f93459d689d990b3ecfbe782fec89b97d3279
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d26c25a9d19b5976b319af528886f89cf455692d
https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.12
https://github.com/torvalds/linux/commit/2a3f93459d689d990b3ecfbe782fec89b97d3279
https://github.com/torvalds/linux/commit/d26c25a9d19b5976b319af528886f89cf455692d
https://nvd.nist.gov/vuln/detail/CVE-2018-18021
https://security-tracker.debian.org/tracker/CVE-2018-18021
https://usn.ubuntu.com/3821-1/
https://usn.ubuntu.com/3821-2/
https://usn.ubuntu.com/3931-1/
https://usn.ubuntu.com/3931-2

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.