Уязвимость BDU:2021-01452

Дата: 15.09.2017. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-01452.

Наименование уязвимости: Уязвимость функции автозаполнения оболочки командной оболочки UNIX Zsh, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость функции автозаполнения оболочки командной оболочки UNIX Zsh связана с переполнением буфера. Эксплуатация уязвимости может позволить нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 17.10 | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» | Операционная система Debian GNU/Linux 10.0 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Прикладное ПО информационных систем Peter Stephenson Zsh до 5.4.1 включительно |

Наименование ОС и тип аппаратной платформы: Ubuntu 1604 LTS 32-bit | Ubuntu 1710 | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Astra Linux Common Edition 212 «Орёл» | Debian GNU/Linux 100 | Ubuntu 1404 ESM |
Дата выявления: 15.09.2017.
CVSS 2.0: AV:L/AC:L/Au:N/C:C/I:C/A:C
Уровень опасности уязвимости: Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,2)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)

Возможные меры по устранению:
Использование рекомендаций:
Для Zsh:
Обновление программного обеспечения до 5.8-5 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета zsh) до 5.3.1-4+deb9u4 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета zsh) до 5.3.1-4+deb9u4 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-3608-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2018-1083.

Тип ошибки CWE: CWE-119
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://www.securityfocus.com/bid/103572
https://bugzilla.redhat.com/show_bug.cgi?id=1548930
https://nvd.nist.gov/vuln/detail/CVE-2018-1083
https://security-tracker.debian.org/tracker/CVE-2018-1083
https://sourceforge.net/p/zsh/code/ci/259ac472eac291c8c103c7a0d8a4eaf3c2942ed7
https://ubuntu.com/security/notices/USN-3608-1

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.