Уязвимость BDU:2021-02777

Дата: 28.04.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-02777.

Наименование уязвимости: Уязвимость сервера DNS BIND, связанная с недостатком использования функции assert(), позволяющая нарушителю вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость сервера DNS BIND связана с недостатком использования функции assert(). Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании с помощью специально созданного запроса
Уязвимое ПО: Операционная система Canonical Ltd. Ubuntu 14.04 LTS | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 16.04 LTS | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Debian GNU/Linux 10.0 | Операционная система ООО «Ред Софт» РЕД ОС 7.2 Муром | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition для «Эльбрус» 8.1 «Ленинград» | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Операционная система Canonical Ltd. Ubuntu 20.10 | Операционная система Novell Inc. OpenSUSE Leap 15.2 | Операционная система Fedora Project Fedora 33 | Операционная система Canonical Ltd. Ubuntu 21.04 | Операционная система Fedora Project Fedora 34 | Сетевое программное средство Internet Systems Consortium BIND от 9.9.3-S1 до 9.11.29-S1 | Сетевое программное средство Internet Systems Consortium BIND от 9.16.8-S1 до 9.16.13-S1 | Сетевое программное средство Internet Systems Consortium BIND от 9.12.0 до 9.16.15 | Сетевое программное средство Internet Systems Consortium BIND от 9.17.0 до 9.17.12 | Сетевое программное средство Internet Systems Consortium BIND от 9.8.5 до 9.8.8 включительно | Сетевое программное средство Internet Systems Consortium BIND от 9.9.3 до 9.11.31 | Операционная система АО «Концерн ВНИИНС» ОС ОН «Стрелец» 1.0 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.7 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 4.7 |

Наименование ОС и тип аппаратной платформы: Ubuntu 1404 LTS | Red Hat Enterprise Linux 7 IA-32 | Ubuntu 1604 LTS 32-bit | Red Hat Enterprise Linux 7 | Ubuntu 1604 LTS | Ubuntu 1804 LTS | Astra Linux Special Edition 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Red Hat Enterprise Linux 8 | Debian GNU/Linux 100 | РЕД ОС 72 Муром | Astra Linux Special Edition для «Эльбрус» 81 «Ленинград» | Ubuntu 2004 LTS | Ubuntu 2010 | OpenSUSE Leap 152 | Fedora 33 | Ubuntu 2104 | Fedora 34 | Astra Linux Special Edition 17 | Astra Linux Special Edition 47 |
Дата выявления: 28.04.2021.
CVSS 2.0: AV:N/AC:L/Au:S/C:N/I:N/A:C
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению:
Использование рекомендаций:
Для РЕД ОС:
https://redos.red-soft.ru/updatesec/

Для программных продуктов Fedora Project:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZDSRPCJQ7MZC6CENH5PO3VQOFI7VSWBE/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VEC2XG4Q2ODTN2C4CGXEIXU3EUTBMK7L/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2021-25214

Для Ubuntu:
https://ubuntu.com/security/CVE-2021-25214

Для программных продуктов Novell Inc.:
Обновление до актуальной версии

Для Bind9:
https://kb.isc.org/v1/docs/cve-2021-25214

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2021-25214

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0114SE47

Для ОС ОН «Стрелец»:

https://strelets.net/patchi-i-obnovleniya-bezopasnosti#kumulyativnoe-obnovlenie
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Данные уточняются
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-25214.

Тип ошибки CWE: CWE-617
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://access.redhat.com/security/cve/cve-2021-25214
https://kb.isc.org/v1/docs/cve-2021-25214
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VEC2XG4Q2ODTN2C4CGXEIXU3EUTBMK7L/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZDSRPCJQ7MZC6CENH5PO3VQOFI7VSWBE/
https://nvd.nist.gov/vuln/detail/CVE-2021-25214
https://redos.red-soft.ru/updatesec/
https://security-tracker.debian.org/tracker/CVE-2021-25214
https://strelets.net/patchi-i-obnovleniya-bezopasnosti#kumulyativnoe-obnovlenie
https://ubuntu.com/security/CVE-2021-25214
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210611SE16
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0114SE47
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81
https://www.cybersecurity-help.cz/vdb/SB2021042903
https://www.debian.org/security/2021/dsa-4909
https://www.opennet.ru/opennews/art.shtml?num=55042

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *