Уязвимость BDU:2021-04838

Дата: 10.05.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-04838.

Наименование уязвимости: Уязвимость компонента net/bluetooth/hci_request.c операционной системы Linux, позволяющая нарушителю выполнить произвольный код.

Описание уязвимости: Уязвимость компонента net/bluetooth/hci_request.c операционной системы Linux вызвана одновременным выполнением с использованием общего ресурса с неправильной синхронизацией «Ситуация гонки». Эксплуатация уязвимости может позволить нарушителю выполнить произвольный код
Уязвимое ПО: Операционная система Red Hat Inc. Red Hat Enterprise Linux 6 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Debian GNU/Linux 9 | Операционная система Canonical Ltd. Ubuntu 18.04 LTS | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Debian GNU/Linux 10 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.2 Advanced Update Support | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.3 Advanced Update Support | Операционная система Canonical Ltd. Ubuntu 20.04 LTS | Операционная система Canonical Ltd. Ubuntu 20.10 | Операционная система Novell Inc. OpenSUSE Leap 15.2 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8.1 Extended Update Support | Операционная система Red Hat Inc. Red Hat Enterprise Linux 8.2 Extended Update Support | Операционная система Canonical Ltd. Ubuntu 21.04 | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Операционная система Novell Inc. OpenSUSE Leap 15.3 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.6 Telco Extended Update Support | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.6 Advanced Update Support | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.6 Update Services for SAP Solutions | Операционная система Debian GNU/Linux 11.0 | Операционная система Linux до 5.12.4 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.7 Update Services for SAP Solutions | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.7 Advanced Update Support | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7.7 Telco Extended Update Support |

Наименование ОС и тип аппаратной платформы: Red Hat Enterprise Linux 6 | Red Hat Enterprise Linux 7 | Debian GNU/Linux 9 | Ubuntu 1804 LTS | Astra Linux Special Edition 16 «Смоленск» | Red Hat Enterprise Linux 8 | Ubuntu 1404 ESM | Debian GNU/Linux 10 | Red Hat Enterprise Linux 72 Advanced Update Support | Red Hat Enterprise Linux 73 Advanced Update Support | Ubuntu 2004 LTS | Ubuntu 2010 | OpenSUSE Leap 152 | Red Hat Enterprise Linux 81 Extended Update Support | Red Hat Enterprise Linux 82 Extended Update Support | Ubuntu 2104 | Ubuntu 1604 ESM | OpenSUSE Leap 153 | Red Hat Enterprise Linux 76 Telco Extended Update Support | Red Hat Enterprise Linux 76 Advanced Update Support | Red Hat Enterprise Linux 76 Update Services for SAP Solutions | Debian GNU/Linux 110 | Linux до 5124 | Red Hat Enterprise Linux 77 Update Services for SAP Solutions | Red Hat Enterprise Linux 77 Advanced Update Support | Red Hat Enterprise Linux 77 Telco Extended Update Support |
Дата выявления: 10.05.2021.
CVSS 2.0: AV:L/AC:M/Au:N/C:P/I:P/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,4)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7)

Возможные меры по устранению:
Использование рекомендаций:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=e2cb6b891ad2b8caa9131e3be70f45243df82a80

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2021-32399

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-32399.xml

Для Ubuntu
https://ubuntu.com/security/CVE-2021-32399

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2021-32399

Для ОС Astra Linux:
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-32399.

Тип ошибки CWE: CWE-362
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://github.com/torvalds/linux/commit/e2cb6b891ad2b8caa9131e3be70f45243df82a80
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=e2cb6b891ad2b8caa9131e3be70f45243df82a80
http://www.openwall.com/lists/oss-security/2021/05/11/2
https://security.netapp.com/advisory/ntap-20210622-0006/
https://lists.debian.org/debian-lts-announce/2021/06/msg00019.html
https://lists.debian.org/debian-lts-announce/2021/06/msg00020.html
https://www.suse.com/security/cve/CVE-2021-32399
https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-32399.xml
https://ubuntu.com/security/CVE-2021-32399
https://security-tracker.debian.org/tracker/CVE-2021-32399
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16
https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.12.4

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *