Уязвимость BDU:2021-05213

Дата: 30.03.2021. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-05213.

Наименование уязвимости: Уязвимость компонента HgDriver менеджера зависимостей для PHP Composer, связанная с внедрением или модификацией аргумента, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании.

Описание уязвимости: Уязвимость компонента HgDriver менеджера зависимостей для PHP Composer связана с неправильной очисткой URL Mercurial-репозиториев. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании с помощью специально созданного URL
Уязвимое ПО: Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 1.6 «Смоленск» | Операционная система Debian GNU/Linux 8.0 | Операционная система Debian GNU/Linux 9.0 | Операционная система Debian GNU/Linux 10.0 | Прикладное ПО информационных систем Nils Adermann, Jordi Boggiano Composer до 1.10.22 | Прикладное ПО информационных систем Nils Adermann, Jordi Boggiano Composer от 2.0 до 2.0.13 | Операционная система ООО «РусБИТех-Астра» Astra Linux Special Edition 4.7 |

Наименование ОС и тип аппаратной платформы: Astra Linux Special Edition 16 «Смоленск» | Debian GNU/Linux 80 | Debian GNU/Linux 90 | Debian GNU/Linux 100 | Astra Linux Special Edition 47 |
Дата выявления: 30.03.2021.
CVSS 2.0: AV:N/AC:L/Au:S/C:P/I:P/A:P
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)

Возможные меры по устранению:
Для Composer:
использование рекомендаций производителя: https://github.com/composer/composer/security/advisories/GHSA-h5h8-pc6h-jvvx

Для ОС Debian:
использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2021-29472

Для ОС Astra Linux:
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0114SE47
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2021-29472.

Тип ошибки CWE: CWE-88
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
https://getcomposer.org/
https://github.com/composer/composer/commit/083b73515d1d72bc61c6374440b3f8a37531f8cf
https://github.com/composer/composer/security/advisories/GHSA-h5h8-pc6h-jvvx
https://nvd.nist.gov/vuln/detail/CVE-2021-29472
https://security-tracker.debian.org/tracker/CVE-2021-29472
https://twitter.com/cyber_advising/status/1388016208193130497
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0114SE47

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *