Уязвимость BDU:2021-05612

Дата: 03.05.2016. Автор: ФСТЭК России. Категории: Уязвимости

Идентификатор: BDU:2021-05612.

Наименование уязвимости: Уязвимость реализации HTTP- или FTP-протокола консольного графического редактора ImageMagick, позволяющая нарушителю осуществить SSRF-атаку.

Описание уязвимости: Уязвимость реализации HTTP- или FTP-протокола консольного графического редактора ImageMagick связана с недостаточной проверкой подлинности выполняемых запросов. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, осуществить SSRF-атаку
Уязвимое ПО: Операционная система Novell Inc. openSUSE 13.2 | Операционная система Debian GNU/Linux 1.2 | Прикладное ПО информационных систем ImageMagick Studio LLC ImageMagick до 6.9.3-10 | Прикладное ПО информационных систем ImageMagick Studio LLC ImageMagick от 7.0 до 7.0.1-1 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Debuginfo 11 SP2 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 6 | Операционная система Red Hat Inc. Red Hat Enterprise Linux 7 | Операционная система Canonical Ltd. Ubuntu 12.04 | Операционная система Novell Inc. OpenSUSE Leap 42.1 | Операционная система Slackware Linux Inc. Slackware 14.0 | Операционная система Slackware Linux Inc. Slackware 14.1 | Операционная система Oracle Corp. Solaris 10 | Операционная система Oracle Corp. Solaris 11.3 | Операционная система Novell Inc. Suse Linux Enterprise Server 11 SP4 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Software Development Kit 11 SP4 | Операционная система Canonical Ltd. Ubuntu 15.10 | Операционная система Oracle Corp. Oracle Linux 7 | Операционная система Canonical Ltd. Ubuntu 14.04 ESM | Операционная система Debian GNU/Linux 8 | Операционная система Novell Inc. Suse Linux Enterprise Server 11 SP3-LTSS | Операционная система Novell Inc. Suse Linux Enterprise Desktop 12 SP1 | Операционная система Novell Inc. Suse Linux Enterprise Server 11 SP2-LTSS | Операционная система Novell Inc. Suse Linux Enterprise Server 12 SP1 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Software Development Kit 12 SP1 | Прикладное ПО информационных систем Novell Inc. SUSE Manager 2.1 | Прикладное ПО информационных систем Novell Inc. SUSE Manager Proxy 2.1 | Операционная система Oracle Corp. Oracle Linux 6 | Операционная система Novell Inc. Suse Linux Enterprise Desktop 12 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Workstation Extension 12 SP1 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Workstation Extension 12 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Software Development Kit 12 | Операционная система Slackware Linux Inc. Slackware -current | Операционная система Canonical Ltd. Ubuntu 16.04 ESM | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Debuginfo 11-SP3 | Прикладное ПО информационных систем Novell Inc. SUSE Linux Enterprise Debuginfo 11-SP4 | Операционная система Novell Inc. Suse Linux Enterprise Server 12 | Прикладное ПО информационных систем Novell Inc. SUSE OpenStack Cloud 5 |

Наименование ОС и тип аппаратной платформы: openSUSE 132 | Debian GNU/Linux 12 32-bit | Red Hat Enterprise Linux 6 | Red Hat Enterprise Linux 7 | Ubuntu 1204 | OpenSUSE Leap 421 | Slackware 140 | Slackware 141 | Solaris 10 | Solaris 113 | Suse Linux Enterprise Server 11 SP4 | Ubuntu 1510 | Oracle Linux 7 | Ubuntu 1404 ESM | Debian GNU/Linux 8 | Suse Linux Enterprise Server 11 SP3-LTSS | Suse Linux Enterprise Desktop 12 SP1 | Suse Linux Enterprise Server 11 SP2-LTSS | Suse Linux Enterprise Server 12 SP1 | Oracle Linux 6 | Suse Linux Enterprise Desktop 12 | Slackware -current | Ubuntu 1604 ESM | Suse Linux Enterprise Server 12 |
Дата выявления: 03.05.2016.
CVSS 2.0: AV:N/AC:M/Au:N/C:N/I:P/A:N
Уровень опасности уязвимости: Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,4)

Возможные меры по устранению:
Использование рекомендаций:
Для ImageMagick:
https://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=29588
https://www.imagemagick.org/script/changelog.php

Для программных продуктов Novell Inc.:
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00024.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00025.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00028.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00032.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00051.html

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2016-3718

Для Debian GNU/Linux:
http://www.debian.org/security/2016/dsa-3580
https://lists.debian.org/debian-lts-announce/2018/06/msg00009.html

Для Slackware:
http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.440568

Для программных продуктов Oracle:
http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html

Для Ubuntu:
http://www.ubuntu.com/usn/USN-2990-1
.
Статус уязвимости: Подтверждена производителем
Наличие эксплойта: Существует в открытом доступе
Информация об устранении: Уязвимость устранена
Идентификаторы других систем описаний уязвимости: CVE-2016-3718​.

Тип ошибки CWE: CWE-20, CWE-352
Ссылки на источники:
cайт ФАУ «ГНИИИ ПТЗИ ФСТЭК России».
http://git.imagemagick.org/repos/ImageMagick/blob/a01518e08c840577cabd7d3ff291a9ba735f7276/ChangeLog
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00024.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00025.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00028.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00032.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00051.html
https://access.redhat.com/security/cve/cve-2016-3718
http://www.debian.org/security/2016/dsa-3580
http://www.openwall.com/lists/oss-security/2016/05/03/18
http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
http://www.securityfocus.com/archive/1/538378/100/0/threaded
http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.440568
http://www.ubuntu.com/usn/USN-2990-1
https://lists.debian.org/debian-lts-announce/2018/06/msg00009.html
https://security.gentoo.org/glsa/201611-21
https://www.exploit-db.com/exploits/39767/
https://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=29588
https://www.imagemagick.org/script/changelog.php
https://nvd.nist.gov/vuln/detail/CVE-2016-3718

Об авторе ФСТЭК России

Аккаунт для добавления уязвимостей с банка данных угроз безопасности информации ФСТЭК России. Не является оф. аккаунтом ФСТЭК России.
Читать все записи автора ФСТЭК России

Добавить комментарий

Ваш адрес email не будет опубликован.